Matomo doesn't work anymore - Syntax Error


(Jürgen Weiland) #1

Hi guys,
is there anyone able to help me out of the following situation?
I am running Matomo since a few years and I’ve recently updated to the lastet version. After updating everything worked like expected BUT since last night I only see the following message while opening my Matomo login page:
An error occurred
syntax error, unexpected '‘You’ (T_ENCAPSED_AND_WHITESPACE), expecting ‘)’

Any suggestion how I could fix this?
Do I need to reinstall the latest version again.
Will the MySQL database still be working? I have lots of different website tracking protocols on the database. Would be a pity to loose data.

Thanks so much for any advice

Jürgen


(Fabian Dellwing) #2

Please take a look at your errorlog and check if it contains a more specific error.


(Jürgen Weiland) #3

Hi Fabian. Thanks for your advice but where do I find the error log?
Thanks for letting me know again.
Jürgen


(Fabian Dellwing) #4

(Lukas Winkler) #5

Hi,

It seems like some file got corrupted.

Can you check if there is disk space left on your server and maybe replace all files with the ones from the latest version?
https://matomo.org/docs/update/#the-manual-three-step-update


(Jürgen Weiland) #6

Thanks for all your prompt help and suggestions! This I appreciate a lot!

This is what fixed the problem:
Reinstalled the lastet version of Matomo in a new folder. Before I’ve tried to install the latest version in the old root, that wasn’t successful!
Brought back the config.ini.php file and Matomo runs like nothing happened with the same Database and works like expected :blush:
This is great news!


(Lukas Winkler) #7

Perfect.

Just keep in mind that there are a few things apart from config.ini-php that you may want to configure again as they are saved in the old path:

  • installed plugins (but not their settings)
  • custom brand logo and favicon
  • GeoIP database