Matomo DNT is disabled in GDRP settings, but doesn't track the DNT enabled visitors

I disabled DNT support in Settings > Privacy > Users opt-out > Support Do Not Track preference: it’s set to Disable Do Not Track support (not recommended)
But when visitors have DNT enabled in their browser, it doesn’t count their visits. Isn’t disabling this setting suppose to make matomo ignore the DNT header? Idk but that was my understanding! Actually, even if I enable this setting, it still doesn’t count the DNT enabled visitors.
This problem presented itself since the beginning when I installed matomo, I did a bit of searching and failed to fix it, didn’t really find anything useful for this issue.
I just don’t understand what the problem is!?



You can try temporarily enabling tracking debugging:

Then the matomo.php request will return a verbose log on why the request wasn’t stored.

Maybe the user are having an adblocker that’s blocking the request no matter how they have set DNT.

1 Like

Thank you for your answer.

That’s exactly it, I actually wanted to mention this in my original post but thought to wait to see if anyone says it, which you did.
So now the question is: Aren’t adblocker addons behave (kind of) like DNT? I know they’re much more advanced, but do they send some sort of other signal besides the DNT header? If so how do I make piwik ignore it?
i.e. I want matomo to ignore all the stuff user’s browser has enabled (DNT, adblocker, etc.) to disable being tracked and counts their visits nevertheless (Yes! I guess I’m pretty harsh when it comes to my sites analytics logs! I do respect privacy and stuff of that matter, but this is different you know? )

… (pointless text so the forum editor allows sending the post. 20char limit…)

Well the point of most browser extensions like uBlock Origin is to block requests that match certain rules. So you can’t just set Matomo to ignore that as the requests containing e.g. matomo.js are blocked.

So you mean if I rename matomo.js (or something like that) it might not get blocked?

I see the same problem. The FF developer console shows, that the request ist executed. If I enable debugging in matomo, I can’t see any reason, why the collected data ist not analyzed. It states “DoNotTrack support is not enabled, skip check” but the request doesn’t show up in the tracking data listings.

Hi @dtm
Can you share the network log of your browser, and the server access log where the request appears?