Manually upgrade from 2.0.3 to 2.1.0


#1

Hi,

I tried to manually upgrade from 2.0.3. to 2.1.0 without any success. (The automatic update cannot be used due to firewall restrictions.)

I downloaded and copied the resource files according to Update Piwik - Analytics Platform - Matomo. After file copy I’m not able to login. The configuration settings for the superuser seem to be ignored and the database was not updated. Now I’m in a deadlock situation (at least I think so). A manually database upgrade calling php index.php – “module=CoreUpdater” was also not successful…

Does anyone have a hint how to solve that issue (without losing all tracked data)?

(Update: deleting the config - file and restarting the installation routine is also not possible, due to missing database upgrade.)

regards


#2

Hi.

Did it gave you a message “…Dry Run” ?
ALTER TABLE piwik_user ADD COLUMN superuser_access tinyint(2) unsigned NOT NULL DEFAULT ‘0’ AFTER token_auth;
UPDATE piwik_option SET option_value = ‘2.0.4-b8’ WHERE option_name = ‘version_core’;

If so you probably will have to run the ALTER … through phpMyAdmin for example.

But be carefull during it i’ve lost the admin access in the database and had to change in the piwik_user table one user to superadmin so i could login and recreate a user for me again.
That means it would be usefull if you have another user with just viewer premissions that you know the password to gain admin access again. (that’s how it worked for me)

Note: didnt reported this problem before because i was thinking that my instalation was not good. Sorry for it.

Hope it helps.

Hugo

EDIT: It seems that if you use the “Update Piwik” through the browser it works with no problems, i think this is only happening when using the command line.


#3

Hi Hugo,

I have a similar issue. I lost super user access after the upgrade but i am able to login with view only user. I am not sure how to get my super user access back. Can you please help me here?

Thanks,
Sandeep


#4

Hello,

I faced similar issue after upgrading to 2.1.0

Here is the solution that worked for me.
Renamed /conf/config.init.php to a different name and then accessed the piwik as if starting installation.
Provided same database as old database (manually upgraded) and selected option to reuse existed tables.

It allowed me to enter new super user details and all happy after. Hoping that this solution helpful.

It seems new piwik has password length minimum of 6 characters. In my case, previous super user password is less than 6 characters.
Wondering this may caused the issue. Please share your experiences.

Thanks,