Magento Shop geht nach Piwik Aktualisierung nicht mehr


#1

Guten Abend,
wir haben in unserem Magento Shop bereits seit langem Piwik als tracking System im Einsatz.
Nun seit gestern hatten wir plötzlich das Phänomen, dass der Onlineshop unwillkürlich ausgestiegen ist und wieder die /install Seite angezeigt hatte (obwohl diese nicht mal mehr auf dem Server vorhanden ist). Nun denn alle Alarmglocken haben geschlagen und ich habe den Übeltäter versucht ausfindig zu machen. Heute ist mir dann aufgefallen, dass unser Piwik plötzlich ein neues Design hat. Und siehe da als ich daraufhin als ich Piwik offen hatte versucht hatte auf unseren Shop zu gehen, wurde dieser mal wieder nicht angezeigt. Nach einigen versuchen stand fest, dass wenn ich mich auf der Dashboard des neuen Piwiks bewegte unser Shop unwillkürlich einfach aussteigt. Bleibt man aus Piwik draußen, läuft alles ganz normal ohne Probleme. Habe dann weitere versuche unternommen herauszufinden woran es denn genau liegt und habe mal den Tracking Code von Piwik aus der Homepage rausgeschmissen. Danach lief dann auch der Shop weiter ohne einen Ausstieg.
Ich habe noch den Code verglichen ob dieser sich seit dem Designwechsel geändert hatte aber es war der selbe wie er schon eingebaut war.
Alle Mitarbeiter von unserem Shop haben mir hoch und heilig versprochen auf keinen Updateknopf in Piwik gedrückt zu haben oder einen gesehen zu haben.

Kennt das Problem jemand? Wenn ja, was kann man da machen? Kann Piwik automatische Updates durchführen ?

Grüße Flo


#2

Hi,

ich habe das gleiche Problem mit einer Php Seite.
Das:
301 Moved Permanently

het geholfen, aber ich hab keine Ahnung, wie stabil die neue Version läuft und vor allem richtig zählt…

Gruß
Sam


(Stefan Giehl) #3

Hi,

Piwik führt keine Updates automatisch aus.
Irgendjemand muss die Aktualisierung angestoßen haben.

Hast du Zugriff auf das Error-Log? Welche Art von Fehlern treten denn auf wenn der Shop aussteigt?

Läuft der Shop und Piwik auf dem selben Server? Möglichweise reicht der Ram nicht aus wenn Piwik die Daten berechnet und gleichzeitig zu viele Leute den Shop besuchen.


#4

[quote=Samuel]
Hi,

ich habe das gleiche Problem mit einer Php Seite.
Das:
301 Moved Permanently

het geholfen, aber ich hab keine Ahnung, wie stabil die neue Version läuft und vor allem richtig zählt…

Gruß
Sam[/quote]
WOW! Das scheint tatsächlich geholfen zu haben!!
Habe das Dashboard offen und kann nebenher im Shop browsen ohne, dass dieser abstürzt!

@SteveG
Jo das mit dem Update habe ich schon vermutet… die sagen auch immer “Nein die Toolbar war einfach da ich habe nix gemacht…” …ist klar… :slight_smile:
Wegen der Error.log, das war am Anfang auch meine Idee und habe in meinem vhost den error level auf debug gestellt, allerdings hat er “KEINE” Fehler ausgeworfen auch die /var/log/message und apache error.log hat geschwiegen. Von daher ein sehr kurioser Fehler aber wie im anderen Thread beschrieben muss man in der /core/FrontController.php die Zeile 305:


libxml_disable_entity_loader(); // prevent remote file inclusion

auskommentieren. Was da Piwik angestellt hatte will ich gar nicht erst wissen…
Grüße Flo


#5

Hallo,
ich bin hier nur vorbeigeschneit, um nachzusehen, ob andere das neue Design auch so unübersichtlich finden wie ich und jetzt durch Zufall über den Verursacher der Probleme bei unserem Magento-Shop gestoßen, die mich schon seit Stunden beschäftigen!

Liegt’s am Tracking-Code? Hat sich da was geändert?

Da muss dringend eine Lösung oder ein Downgrade her. Für mich ist der Verlauf des Problemes völlig schleierhaft.

Jedenfalls kann ich den Zusammenhang bestätigen!!

Habe über Teamviewer getestet, ob das Problem auch auf einem anderen Rechner auftritt und dem ist so. Meine erste Vermutung war, dass es nur den Rechner betrifft, mit dem man bei Piwik eingeloggt ist. Sobald ich aber in Hamburg durch Piwik klicke, erscheint auch in Österreich der Shop plötzlich mit der Installationsseite!

Grüße


#6

Also, der Versuch, den Tracking-Code auszutauschen hat keine Veränderung gebracht. Weiterhin der Redirect zu /index.php/install

Hab jetzt wieder ein Downgrade auf die alte Version mit Einspielen der Piwik-DB von gestern durchgeführt, bis es eine funktionierende neue Version von PIWIK gibt.

Nach dem Downgrad freue ich mich übrigens wieder über ein übersichtliches Design!


#7

Es betrifft mich zwar nicht, aber FloxRoxX hat doch die Lösung oben gepostet.

Hier nochmal von einem Piwik-Dev:
http://forum.piwik.org/read.php?2,108366,page=1#msg-108368

Ist wohl ein PHP Bug:
https://bugs.php.net/bug.php?id=64938

Die Einstellungen bewirkt, das auf allen Seiten des Servers wohl diese Funktion ebenfalls abgeschalten wird.


#8

Hmmm… okay - damit gibt es zumindest für den Moment einen Workaround.

Ich pfusch nur nicht gern im Source-Code von Installationen rum, die updatefähig bleiben sollen. Ich hoffe, da gibt’s bald mal einen integrierten Fix (auch für’s quarkige neue Template ;))!


#9

Wurde wohl mit 2.0.2 gefixed.