Login loop and permission errors with installation 0.5.4


(Judder) #1

Having some issues with 0.5.4 from the latest.zip

When unpacked, running the installed gives an immediate

Error: Unable to mkdir /var/www/vhosts/–blah–/piwik/tmp/sessions

Changing the permissions from the command line then can fix this, but once installed a successful login just loops back to the login page (with correct or incorrect password and no message).

Any suggestions or has anyone seen this before?


(Judder) #2

Weird bug - it looks like it had removed the ‘admin’ account when it failed the auto-update, and then because tables already existed, the new 0.5.4 install didn’t recreate it (even though it asked for it during setup).

Perhaps the admin account should be checked/created even if re-using existing tables?


(schoenswetter) #3

I have exactly the same problem. Even changing the folder permissions doesn’t work for me.


(eckilha) #4

Hi,

I had a similar problem. I relaunched my website (without modifying my piwik folder) and then there appeared the same error message. I manually created the sesssions folder and changed the rights in my ftp client and then piwik told me that I use an old php version (4.x). When I switched to php5 everything worked well.

In my case I just added this line to my .htaccess file

AddHandler php5-cgi .php

I hope that this will help you!