Local mountain lion os x install permission problems


#1

I’m trying to install piwik in a local OS X development environment but am running into permissions problems.

here is what the install error message reads:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your server, to allow Write access on these directories:


chown -R www-data:www-data /Users/me/Sites/project/piwik
chmod -R 0755 /Users/me/Sites/project/piwik/tmp
chmod -R 0755 /Users/me/Sites/project/piwik/tmp/templates_c
chmod -R 0755 /Users/me/Sites/project/piwik/tmp/cache
chmod -R 0755 /Users/me/Sites/project/piwik/tmp/assets
chmod -R 0755 /Users/me/Sites/project/piwik/tmp/tcpdf

The first line above doesn’t work - Terminal tells me:


chown: www-data: illegal group name

The second command worked, but the rest didn’t as the directories weren’t yet created. I created them then re-ran the commands and those all worked.

Any help for how to deal with the error I get from running the first command above?


#2

You need to use the user and group that your local web server is running. www-data is an Ubuntu related one, maybe some other OS’s as well, but its not OSX related.

Perms go like this

 User:Group 

If memory serves me correctly on OSX you should do something like this

 sudo chown www:www file.name 

Don’t forget the

sudo chown -R www:www file.name

if you need to recursivley change.


#3

Thanks vwyoda!! Problem solved. Can’t wait to start using Piwik.


(Zeeshan Aslam) #4

@vwyoda I got what I was looking for. Thank you so much. You are awesome. :grinning: