Live! gruppiert nicht mehr nach Update


#1

Hallo zusammen,

ich habe heute morgen ein Update auf 1.1 gemacht. Seitdem wird jeder Klick auf meiner Seite im Live-Widget einzeln angezeigt, auch wenn ein User mehrere Seiten anklickt, ohne diese zu verlassen.

Es wird auch jeder Klick als einzelner Besuch gezählt. Was stimmt denn da nicht?


(Thomas Seifert) #2

gibt noch zwei weitere Reports dieser Art:
http://forum.piwik.org/read.php?2,70483
http://forum.piwik.org/read.php?2,70446

Am besten mit im Ticket melden Wrong stats after 1.1 upgrade · Issue #1939 · matomo-org/matomo · GitHub , um die Wichtigkeit zu erhöhen.


(dealer) #3

habe das gleiche Problem…


(Fabian Becker) #4

Bitte auf 1.1.1 updaten. Das Problem sollte behoben sein.


(dealer) #5

[quote=“Fabian Becker”]
Bitte auf 1.1.1 updaten. Das Problem sollte behoben sein.[/quote]
habe gerade das update gemacht. Leider werden die Besucher zeitlich nicht richtig sortiert.
tmp Ordner wurde auch geleert, sowie cookies.
Neu angemeldet brachte auch nichts.


(Fabian Becker) #6

[quote=dealer]
habe gerade das update gemacht. Leider werden die Besucher zeitlich nicht richtig sortiert.
tmp Ordner wurde auch geleert, sowie cookies.
Neu angemeldet brachte auch nichts.[/quote]

Die Sortierung sollte eigentlich gefixt sein. Da habe ich gestern einen Bugfix committed. Kannst du mir Zugriff auf deine Installation geben (Zugangsdaten per PN) damit ich das besser debuggen kann? Den Fehler kann ich bei mir nicht reproduzieren.


#7

Moin,

ein Update auf 1.1.1 fixt das Problem nicht, wie matthieu hier auch deutlich gemacht hat.

Auch das Löschen des tmp-Ordners und der Cookies hat nur perifer Abhilfe geschaffen. Wie zu erwarten war, haben die Besucher noch die alten Cookies und deswegen geht das mit dem konfusen Besucherzählen munter weiter.

Abhilfe würde ein Cookie schaffen, das nach X Stunden ungültig wird.


(dealer) #8

habe mal einen screener angehängt, was so alles passiert…


(Fabian Becker) #9

dealer, öffne bitte mal den Quelltext der Webseite (also von Piwik) im Browser. Steht dort: ?


(dealer) #10

(dealer) #11

habe jetzt wieder auf die 1.1.1 updated, der gleiche Fehler: die visitors werden laufend durcheinander angezeigt, nicht mehr sortiert, und die besuchten Seiten zusammen gezählt.
Ordner assets geleert…


(dealer) #12

das Live Plugin aus der 1.0 funktioniert perfekt.

update:
auch hier gibt es die gleichen Fehler, dass die Sortierung nicht stimmt.