Last visits graph is showing incorrect data


#1

Hi:

I dont know if anybody has the same issue. Since i update the system to 1.2.1 the “last visits graph” is showing wrong information. I assume its just a change in calculation but i need further information.

Previous to the update i has +4000 visits per day in one of my configured sites. After the update i have now 1200 visits. My boss is asking why this loss of data, and i cant give him a hint about that.

Any idea on this matter?

Thanks in advance
Alberto


(Matthieu Aubry) #2

The processing for visits has not changed, so maybe there is another problem. Can you check your error logs to see if there is a problem?

otherwise, can you look at your referrer stats to see if some referrer maybe bring less visits?


#3

Nothing in the apache2 error log. Only this but it doesn´t affect:

[Sun Apr 24 06:39:26 2011] [error] [client 124.115.6.14] File does not exist: /home/ulysse/datos/www/piwik1.gowex.com/robots.txt

When i check actions graph under “visitors” -> “overview” the data after the day i did update the system behaves the same way. All data are reduced by 75%.

Any ideas on how i can debug this situation?

thanks in advance
Alberto


(Matthieu Aubry) #4

do you have another stats tool, for example AWStats available, to see if traffic on your server decreased?


#5

I have something better. I have installed a piwik older version at piwik2.gowex.com, and a new code into the website pages. Old version show original stats, but the newer one show 75% down as i said before. And when i update any older version to an updated one, the visitors graph falls down. In can create one profile in both piwik sites if you want to enter and see for yourself.

I have also an awstats but it wasn´t already installed, so i dont have previous data to compare.

Any thoughts?

Thanks a lot
Alberto


(Matthieu Aubry) #6

What about page views? there were a few bugs in older Piwik that were overcounting visits, counting each page as new visit. But if page views, also show less traffic, then maybe there is a bug in piwik!


#7

Pageviews match in this way:

Reference, yesterday April 25th 2011
Older version
3653 Visits
1062 unique visitors
In this version i dont see actions per visit, but i saw before update 1.8 to 2.0 actions per visit, wich is consistend with data loss.

Newer Version
1190 visits
440 unique visitors
6.3 actions per visit

In short, i think data are colleted differently, now system counts less visitors but more actions per visit since the upgrade.
The new version 1.3 does not fix this.

This site is visited exclusively from a bus network and all visitors come to this site from a single ip, despite wich bus are using.

Thanks a lot Matt
Alberto


(Matthieu Aubry) #8

OK because of bus network, I think the problem is as follows:

please try the config change in How to - Analytics Platform - Matomo


#9

Ok Matt:

I am going to try this setting and in a couple of days i´ll tell you something

Thanks for he tip.
Alberto


#10

Hi Matt:

Two thing to point out.
the day in wich a changed the setting you gave me, is blank (no data the hole day). This setting was applied at the end of the day and data was full.
Now the data does not match with the older version of piwik for the same domain.

Any ideas?

Thanks in advance
Alberto


(Matthieu Aubry) #11

please, can you try the latest RC: 301 Moved Permanently


#12

i am on it thanks
Alberto