Keywords missing from search engines after upgrade to v1.5.1


#1

Hi there, I am facing a problem with piwik on a certain website since I upgraded to version 1.5.1.

The problem is with the keywords that seam not to show up at all for most visits that come from Google. 6 out of 10 visits from Google as referrer have no keywords. I checked the .htaccess for any weird entries and things look clear to me. I got no idea what to do, I thought of re-installing. Weird is that same day I upgraded more sites that do not face this problem.

Any idea of what I could do to solve this ?

Thanks and congrats for the software.

Edit://
If I mouse-over a referrer in piwik with the keywords missing, I can truly see in FF something like this: Зображення Google


#2

I see no help on this one,
at least is there any way to keep the database and do a fresh install without losing stat data ?


(vipsoft) #3

(What version of Firefox are you using? I don’t think Piwik has been extensively tested with the latest version.) Can you try with a different browser?

Since the hover text is displaying correctly, it’s probably not a database problem. Probably some encoding issue when the HTML for the data table is generated. Can you see what the DOM looks like with Firebug?


#4

oh ok let me check didn’t think of that !
thanks

Edit://
using ff 6.2


#5

ok so I am on a win7 machine right now and tested on:

FF 6.0.2
Google Chrome v14.0.835.186
IE9 v9.0.8112.16421 64bit
Opera v11.51
Safari 5.1 (7534.50)

same problem on all.

What shall I look for in firebug/DOM ?

thanks

Edit://
want access to take a look >?

Edit 2:
by the way, the keywords widget as well as the Referrers > Search Engines & Keywords section show nothing for today, although I can see keywords on mouse-over on Visitors in Real Time widget


#6

So, is there no solution to this one ? Does that mean that in such cases I wipe out piwik and start from the beginning hopping it won’t just happen again ? …cause I have done nothing wrong on my own as far as I can understand.

It would just be nice to keep statistics you know.


(vipsoft) #7

PM either Matt or myself with a link to this topic, and provide login details to your dashboard.


#8

thanks ! :smiley:
pm sent to you, please check it.
many thanks


(vipsoft) #9

Works for me. The only thing you might want to check is that you have Arabic fonts installed on your PC.


#10

weird it works for you, once I am checking right now using an ubuntu 10.04 on ff and same result.
I don’t have arabic installed on win7, I haven’t touched the fonts at all.
same result on windows xp from 2 different computers.

this is how it looks to me (check attachment)
any ideas ?


(vipsoft) #11

Ah. This is already fixed in trunk.


#12

you mean its fixed in the upcoming version ?
if there is a link related please give me thanks !


(vipsoft) #13

Google Mobile Image Search not recognized · Issue #2569 · matomo-org/matomo · GitHub - handles the changes to the Google Images referrer URL


#14

thanks very much, it looks like after I upgraded to version 1.6 the problem is gone, although I would like to know how I can correct the database, once the previous visits remain the same not showing keywords etc.

is there any way ?
thanks very much, cheers