JSON Parse Syntax Error while trying to view today's stats


(_Austin) #1
Open Flash Chart

JSON Parse Error [Syntax Error]
Error at character 0, line 1:

0: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')

I’m trying to view today’s stats but they don’t seem to be updating. When I click on today’s date to view this error shows up in the visitor modules. Any ideas?


(vipsoft) #2

Please check the timezone setting in php.ini matches the MySQL timezone.


(_Austin) #3

That worked, thanks.

Though I would like to bring up another issue, coincidence I’m sure, but when I put this post up my site was bombarded with visits mostly looking for some access to different versions of my database through various forms of phpMyAdmin in the url. The only reason I bring this up here is because at that same time Piwik is reporting that some are coming from “www.phpmyvisites.net” and “www.phpmyvisites.us” as well as some urls pointing to “/?piwik_campaign=fdfff” Piwik campaigns that don’t exist.

If you have any input toward this that would be nice.


(vipsoft) #4

Did you click on the link to generate visits? The sample data is pumped into idsite 1.

We’ll be putting in an “Are you sure?” prompt in a later release.


(_Austin) #5

No, I think it was because I was being foolish and playing around with:

always_archive_data_period = 0;
always_archive_data_day = 0;

Thanks for your help.


(Tony) #6

I’ve just set up Piwik and got the same problem (or similar).

I am getting error

a:2:{s:6:“result”;s:5:“error”;s:7:“message”;s:282:“SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND name IN ( ‘max_actions’, ‘nb_uniq_visitors’, ‘nb_visits’, ‘nb_ac’ at line 3”;}

at “Last visits graph”.

Please give a detailed instruction how to fix it, if you can.


(vipsoft) #7

Change the date.timezone setting in php.ini to match the timezone of the MySQL server. You’ll find a list of supported timezones at PHP: List of Supported Timezones - Manual


(Christian Schneider) #8

Hi.

I got the same problem, but not always only sometimes and I hade several sites not with all. Any idea?

Best regards,
Christian.


(vipsoft) #9

Christian: did you set date.timezone in php.ini? what version of piwik are you running?