JS Tracking Not Tracking

I’ve been trying to get piwik working for six hours now. The python script import works but the JS tracking doesn’t. The tracking code appears to be correct because it generates the new tag as expected. Originally my site was routed through CloudFlare and after migrating off and using Let’s Encrypt certs, the situation hasn’t improved.

  • System Check No Problems
  • Piwik 3.2.0
  • Ubuntu 16.04

I thought maybe it’s a permissions issue or DB issue but if the python server log import works then that makes it unlikely.

Any ideas? Site in question: https://canpicker.com/

It’s seems to be an issue with cross domain, because I can access https://stats.restfulcms.com/piwik.js directly in the browser, but from Network status it is not being loaded.

I also found it odd it didn’t show up in the network tab. Any idea why this might happen? Does Piwik have some CORS setting I need to tweak or what?

Update: Yep there’s a CORS setting. cors_domains[] = *. Adding it into my config.ini.php doesn’t seem to improve things though. piwik.js still doesn’t show up in the network tab and I don’t see any errors complaining about CORS.

Do you own restfulcms.com domain? It could be a configuration on that domain that doesn’t allow files to be download from another domains.

I do and off the top of my head I don’t see why it wouldn’t. Normally when there’s a CORS problem the browser should throw up a warning no? I’m currently seeing if I can get it working on stats.canpicker.com and see if that gets it working.

Fixed. Issue was with nginx config.
This block solved the problem: net::ERR_EMPTY_RESPONSE:The server closed the connection without sending any data." · Issue #34 · perusio/piwik-nginx · GitHub.