Javascript doesn't track - net::ERR_EMPTY_RESPONSE


#1

Hello,

I can’t seem to get javascript tracking to work with my piwik installation. I have tested piwik using the tracking pixel and it works just fine. I have read the javascript the JavaScript Tracking Client: API Reference - Matomo Analytics (formerly Piwik Analytics) - Developer Docs - v3 article and it hasn’t helped me much in debugging the problem.

When I open up the console.log() in chrome it gets the following error - net::ERR_EMPTY_RESPONSE. I am not sure how to fix this problem.

Also I am running nginx without ssl.

Also my piwik javascript code is as follows:


#2

this is a chrome issue… does the error occur in firefox or safari?

try in chrome

  1. There is a problem with your ISP internet connection.
  2. Google Chrome specific issue usually resolved by just clearing your cache or disabling Extensions.
  3. Faulty Router or a Router misconfiguration.
  4. Spyware, adware or malware installed on your computer or in your Browser.
  5. Corrupt or invalid Registry keys on your computer.
  6. Corrupt cache in your computer’s Temporary Internet folder that requires manual deletion by going to the Temp folder and deleting that cache.

if that doesnt help try, checkinh yout htaccess or try changing your dns to 8.8.8.8 and see if that helps


#3

I do not believe this is a chrome as I am using chrome to debug why the javascript piwik tracker isn’t working. The pixel tracker works.

I am using chrome console’s Using the Console  |  Tools for Web Developers  |  Google Developers to get the error. There this error is not displayed to regular users of a website, you have to use a javascript debugger to get the error.


#4

ROFL. Never mind. Damn Avira.