$ is not defined


#1

Hi, I successfully installed PIWIK 2.7.0 yesterday. No Errors on installation. However the dashboard is empty because of a JS error in all bowsers I tried ($ ist not defined - line 58). It seems to me that jQuery ist not loaded.

Strangely enough this also happens on the PIWIK demo installation (http://demo.piwik.org/).


(Matthieu Napoli) #2

Hi,

If that happens for you on the demo too I would say it has probably something to do with your browser? Maybe an extension or a setting or something that blocks jQuery from being included?

Could you try with another browser, or even another computer?

Cheers


#3

Hi, thanks for your reply, Matthieu. Indeed the problem is only existent at my office where all web-traffic is scanned by GFI WebMontor. Turning it off for that specific website solved the problem. I never would have thought of that because we never had this kind of problems with other websites.

Regards, Chris


(Matthieu Aubry) #4

Thanks for letting us know that GFI WebMontor causes incompatibility with Piwik.

Do you think maybe you could contact this vendor and kindly ask them to make their software compatible with Piwik?

Otherwise I’m afraid that this issue will occur again for you or other people :slight_smile:

Thanks,