Invalid API module and/or API action - since 2.14.0


(Axel Hahn) #1

Hi,

since update to 2.14.0 I get an error on API reqest for browsers. The image contains
Invalid API module and/or API action

see Metadata: API Reference - Matomo Analytics (formerly Piwik Analytics) - Developer Docs - v3

Example: Horizontal Bar Graph Plotting Browsers for the Current Month
URL: index.php?module=API&method=ImageGraph.get&idSite=3&apiModule=UserSettings&apiAction=getBrowser&token_auth=anonymous&graphType=horizontalBar&period=month&date=today&width=500&height=250

… and there are 2 more broken examples
Example: Graph Plotting User Screen Resolutions for the Current Month
Example: Pie Chart with Custom Colors

Did the API change or is it just broken in the current version?

Regards,
Axel


(Matthieu Aubry) #2

Hi there

can you reproduce this bug on the demo.piwik.org?


(Axel Hahn) #3

Hi Matt,

thanks for the reply.

Yes, you can see it with demo.piwik.org too.

Have a look to the demo graphs on
http://developer.piwik.org/api-reference/reporting-api-metadata
go there to the section “Static Image Graphs” (nearly on the bottom of the page). Here you can see 3 broken images.

This is the problem I have on my current instance too.

Regards,
Axel


(Matthieu Aubry) #4

Axel, thanks for report. I created a bug at: Some static Image graphs are broken · Issue #8923 · matomo-org/piwik · GitHub - we will fix it for next release