Internet Explorer Scriptfehler nach Piwik Update


#1

Hallo Piwik - User,

Bei der Suche im www bin ich leider nicht wirklich fündig geworden.
Nun hoffe ich hier auf den einen oder anderen Profi :slight_smile:

Seit dem Update auf die Version 1.1.1 taucht in meinem Shop-Backend (es wird standardmäßig für die online-Voransicht der Internet-Explorer verwendet) folgender Script-Fehler auf:

"Internet Explorer Script Fehler
In dem Script auf der Seite ist ein Fehler aufgetreten.
Zeile 14
Zeichen 822
Das Objekt unterstützt diese Methode oder Eigenschaft nicht.
Code 0
URL http://localhost:6004/MetaDataWebExport/index.php/de"

Es gibt weder die Zeile noch das Zeichen im Code :S

Der Fehler tritt nach dem Entfernen des Piwik Codes aus der Seite nicht mehr auf.

Ausgeführt wird Piwik korrekt und auch online zeigt kein Browser (auch nicht IE 6-8) diese Fehlermeldung.

Es nervt aber trotzdem, da ich beim Bearbeiten meiner Seiten im Backend bei jedem neuen Laden diesen Fehler wegklicken muss.

Bin für jede Anregung dankbar :-))

LG
Heike


#2

Hallo Heike,

schau mal hier, es scheint gefixt worden zu sein: 301 Moved Permanently

Grüße,
Stephan


#3

Hi Stephan & Alle,

vielen Dank für die Antwort.

Nur nochmal so zur Sicherheit, daß ich verstehe was ich dort sehe…

Ich muss auf dem Server in der Datei “piwik.js” die roten Zeilen durch die grünen ersetzen? (oder nur die fett-roten Stellen durch die fett-grünen?)

Oder gibt es eine Piwik-Version, in der diese Korrekturen bereits enthalten sind?

Laienhafte Grüße
Heike