Internal server error during update to piwik 2.0.3


#1

Hello.
I have problem when im updating piwik to 2.0.3 (from 1.12) i have internal server error.
In error_log i have:

[20-Feb-2013 23:20:58] PHP Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /home/q70794qf/public_html/statystyki.-my-site-.pl/modules/base/templates/options_goal_entry.php on line 256

I was searching on the forum but i haven’t found any ideas.


#2

what php version are you running?


#3

Im runnig PHP 5.4


#4

Would this happen to be a wordpress site? If so some themes need to be updated when getting these types of errors.

Does that apply here?


(Matthieu Aubry) #5

This error: modules/base/templates/options_goal_entry.php on line 256

does not come from Piwik but from another software


#6

[quote=lesjokolat]
Would this happen to be a wordpress site? If so some themes need to be updated when getting these types of errors.

Does that apply here?[/quote]

No Im using Piwik only for normal websites (two written in HTML)

[quote=matt]
This error: modules/base/templates/options_goal_entry.php on line 256

does not come from Piwik but from another software[/quote]

I have no idea what kind of software could make this error.

On those sites I have also installed Google Analitycs, Open Web Analytics and Mibew Chat.