Instead of JS: An error occurred


#1

I set up Matomo 3 (latest release) on top of a Piwik 2 database. So far, so good.

Now when I try to log on, I only get a header with Matomo logo and the Javascript debugger complains: “Reference Error: $ is not defined.”

Checking in HTML source code what Matomo is actually loading, instead of d/l Javascript files directly, it loads them via index.php – very convenient when this generates HTML and not JS.

The HTML complains: “JShrink could not be found, maybe you are using Matomo from git and need to update Composer. $ php composer.phar update.”

I do not care about fuzzied JS. How do I switch this JShrink off? I saw no plug in.


(Lukas Winkler) #2

Hi,

Can you describe how you installed Matomo. Did you run composer successfully if you installed Matomo from git(hub)?

It is really recommended to install Matomo from Download Matomo Free Web Analytics Tool - #1 Open Source Analytics instead of the developer version.


#3

I d/led and installed the official release from Download Matomo Free Web Analytics Tool - #1 Open Source Analytics . Only thing I realised during running /setup was that something complained about not being able to download Javascript. PHP scripts are not allowed to phone outside the intranet, and my browser did not report any other connection than to the local network.


(Lukas Winkler) #4

Hi,

I’d recommend you to check if all files are not corrupted or missing.

You might also want to take a look at How do I configure Matomo on a server without Internet? FAQ - Analytics Platform - Matomo on how to disable all features that need an internet connection.