Installing Piwik 1.5.1 and can't setup database


#1

I am running Piwik on a windows server. I have given full RW permissions for the tmp/ folder and all child folders and also gave same permissions for the config/ folder. I passed the System Check page but when it goes to the Database Setup page it will not install telling me I either skipped a step or do not have cookies enabled.

This is a clean install and there are no config files in this and I’ve tried to put a php.ini that enables cookies in the root of the website docs but it has done nothing to solve the problem.

If I could ask a side question, where does the code for the database setup reside? Maybe I could modify it just to get past this step because I know it’s not true that it can’t continue. However, I have spent an hour trying to figure it out and can’t find where the ‘?action=databaseSetup’ goes to.


(vipsoft) #2

On Windows, you have to use the ACL. For this reason, we have packaged Piwik for Microsoft’s Web App Gallery. I would suggest installing that, and then doing in the in-app upgrade to the latest version. (Yes, we need to package up a new release.)


#3

I can’t just use Web Matrix because it has to be run on the actual sever. I’m running a Windows shared hosting server (stupid as I’ve begun to discover over the years now). Is there really no other way to install it? It can’t be that difficult right?


#4

Chrome can not install but internet explorer can. For some reason this is the reason I got the error and now it works.

I’ve submitted a bug report : Chrome cookie error prevents installation · Issue #2666 · matomo-org/matomo · GitHub