Installation without any problems - no configuration possible

Hi there,

i installed actual piwik flawless on my webserver. But, in backend there are some strange problems:

  1. If i try to set some configurations, they aren’t saved and i get an error “token is wrong”
  2. I do not see the Javascript Code (empty box)
  3. In the tracking tab i can’t set any radio buttons (seems they are disabled)

Does any one know about that strange behaviour?

Best regards

What browser are you using?



i tried it with all major browsers.


It sounds as if some permissions might be wrong in your Piwik installation.

Check these:
Directory “config” and all its contents: universal read/write/execute initially. When Piwik is configured and running, you can set this back to read-only.

Directory “tmp” and all its contents: universal read/write/execute. You may not be able to set permissions on some of this directory’s contents because of “ownership” settings. Don’t worry about that.

Some servers require permissions for PHP scripts to be set to 755 instead of 644. MIne is like that, so I set everything to 755 except where 777 is needed.

Hi. Thanks for that! I did exactly that but i have still the same problems. No Code shown, checkbox could not be checked and in other settings i get an “token not valid”


Try this: Troubleshooting - Analytics Platform - Matomo