Installation Permissions Problems

I’m in the process of moving my Piwik 1.2 install to a CentOS/Plesk cloud server. When I first set up the server I copied my Piwik database over and got Piwik working as it should. Then I went through quite a bit of trouble to get my SSL certificate set up properly, which should be unrelated, but my Piwik install has given me the standard permissions problem on the tmp dirs. ever since. I have even dropped and reinstalled the database and deleted and reinstalled Piwik, but the installer can’t get past the permissions issues. I’ve even set the permissions to 777 and still get permissions errors. Is there some debug or error log where I can see what’s going wrong and how I can fix it?


What errors do you get?

When trying to access my piwik directory to run the setup I get:

[quote="Piwik couldn’t write to some directories.

Try to Execute the following commands on your server, to allow Write access on these directories:

chown -R www-data:www-data /var/www/vhosts/
chmod -R 0755 /var/www/vhosts/
chmod -R 0755 /var/www/vhosts/
chmod -R 0755 /var/www/vhosts/
chmod -R 0755 /var/www/vhosts/
chmod -R 0755 /var/www/vhosts/"]


There is no www-data user, but there is an apache user and the initial time I set it up that it was working I set everything to the apache user. Obviously something changed on the server and I’m not sure where to look to see what’s going. If it was a simple permissions issue then chown apache and chmod 777 should take care of it.

Maybe ask your sysadmin ?

I set up an entirely new cloud instance and am still running into the same permissions issues and I’m not sure what else to try. I load the database and set up the database user from my current piwik installation. I downloaded and unzipped the latest version of piwik, and when I try to access the piwik directory to start the setup, I get the exact same permissions error I pasted before. This is a verio cloud server running CentOS 6.3 with Plesk Panel 11.0.9 Changing permissions to 777 does not solve the problem. I’ve tried changing the owner of the piwik dir and everything under it to my main plesk account, apache, apache:apache, and I even followed the suggestions here for people having permissions problems with word press so they added the apache user to the plesk group and changed permissions to 775 for directories and 644 for files. Nothing seems to work to solve my permission problems.

I asked my hosting support and they didn’t have any useful suggestions. I’m trying to install this on what should be a pretty basic set up. I can’t be the only person that has run into permissions problems with Plesk can I?

@BP77 I’ve also encountered this problem, still trying to figure out the solution!