Installation of Wordpress plugin v.0.2.0 keeps hanging

I have tried to install the plugin on two different websites hosted at Greenhost (shared hosting), and in both cases the installation process never seems to finish. But when I move away from the install page to the plugin directory, it appears the plugin is installed, though not yet activated. After activating it manually, everything works fine.

UPDATE: When installing the plugin on websites hosted at Strato (shared hosting), the installation fails. Either you get an empty screen, or an error message (Secure Connection Failed. An error occurred during a connection to vvedewatertoren.nl) I have double checked and both websites are on the latest WP version (5.2.4), and running on PHP 7.2

UPDATE 2: When I manually upload the plugin via SFTP to Strato websites and activate it via the WP backend, everything works fine.

Hi,

My only guess would be that as the plugin needs to do a lot of things on install and your shared hoster might not be that fast, is that the installation takes long enough that it get’s killed by the max_execution_time of your server.

Hi Lukas, yes, that’s most likely the explanation. It might be a good idea to include this scenario on Matomo Analytics beta for WordPress - Powerful Web Analytics so new beta testers are aware of this possibility. Right now it only suggests to choose a manual upload in case of an explicit error:

During the upload, if you get an error like “Are you sure you want to do this?”, we recommend you upload the extracted zip file on to your server and into your ‘wp-content/plugins’ folder manually using ftp or ssh.

P.S. Unfortunately, with shared hosting, updating the plugin to a newer version from within WP-admin (e.g. from v0.2.0 to v.0.2.4), also results in the installation process grinding to a halt. That is a bit more problematic, as it would take me a great amount of time to manually update Matamo via FTP on 15+ websites. Would you know a way around this?

The plugin will be later available on the WP Marketplace and then it should be less of an issue maybe?

Hopefully yes, but I don’t know whether a different distribution channel (WP Marketplace) will make much of a difference for those who are installing / updating the plugin on a shared hosting environment.

Rene, were you able to upgrade the beta after all?

Yes, after waiting for 10 minutes or so, I went back to the plugin overview in the backend of WP and (re)activated the updated plugin from there. It would be worth including this in the description or FAQ section when launching the plugin in the market place, otherwise you might get lots of negative reviews from people who don’t know what to do in case a plugin (upgrade) does not install automatically. And that would be a real shame, given that your plugin is working so well & so valuable to the community :smiley:

1 Like