Install issue - Cannot use output buffering in output buffering display handlers


(mahdi1234) #1

hi there,

I went thru the whole installation process fine, however now it throws the following error -

Fatal error: ob_start() [<a href='ref.outcontrol'>ref.outcontrol</a>]: Cannot use output buffering in output buffering display handlers in /st/core/ErrorHandler.php on line 31

PHP Version 5.2.5
mysql 5.0.51

Any idea what could be the problem?

thx,
mahdi


(Matthieu Aubry) #2

I would say that you have some special settings in your PHP installation. I can’t reproduce this bug on my machine.

Do you have ZLIB compression enabled? Do you have any other enabled setting that could be interesting or not so common ?
please check your phpinfo(); and let us know


(robocoder) #3

Based on mahdi1234’s settings (ticket 328), I suggested the following .htaccess changes:

php_value output_handler none php_flag register_globals off php_flag safe_mode off

(mahdi1234) #4

[quote=robocoder @ Dec 26 2008, 04:12 PM]Based on mahdi1234’s settings (ticket 328), I suggested the following .htaccess changes:

php_value output_handler none php_flag register_globals off php_flag safe_mode off
[/quote]

Thanks it works. I suggest to update http://piwik.org/docs/requirements/ with safe mode requirement.

cheers


(nikkilorens) #5

Greetings. I too had such problem. Thanks all for answers.


(Matthieu Aubry) #6

Everybody in this topic, did your problem come from the fact that safe_mode was enabled? Did you have to disable safe_mode to get Piwik working? Thanks for your details.