Install error

unziped and uploaded to a site and everything worked fine.

then used the same unzipped files to upload to another site and now keep getting:

Warning: require_once(/home/content/92/3428292/html/(my web site)/pi-stats/piwik/core/testMinimumPhpVersion.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/92/3428292/html/(my web site)/pi-stats/piwik/index.php on line 33

Fatal error: require_once() [function.require]: Failed opening required ‘/home/content/92/3428292/html/(my web site)/pi-stats/piwik/core/testMinimumPhpVersion.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/92/3428292/html/(my web site)/pi-stats/piwik/index.php on line 33

got a new zip from pikwik, unzipped and uploaded and got same warning.

and yes, i checked to make sure the testMinimumPhpVersion.php was in /core/ and even uploaded that file again.

any ideas what i screwed up?

What php version is running on that 2nd site?

Maybe the permissions are not high enough on the file? or maybe it needs to be chmowned by the webserver?

Can you try upload latest:

using php5.1.3rc

well this was a learning process.
Up until now I have used ftp with it set to Force Lower Case.
Never had a problem with any program set up.

Error keep telling me that testMinimumPhpVersion could not be found.
On my server it is written as testminimumphpversion

So I name changed it using the capital letters:

And that file was then found, leaving me an error that ErrorHandler could not be found, so changed the name, and then ExceptionHandlercould not be found so changed the name.
Then got a Fatal error: Class ‘Piwik_FrontController’ not found.

So I decided as Matt suggested to get the new build, and I ftp’d it without forcing lower case.

And got Internal Server Error.

Looked and saw that index.php was set to Read Only!
So I set it to execute.
Everything then worked perfectly.

What a trip.

@davarian… nice, we are always learning :wink: