Install 403 error no mod_security installed


#1

Having a problem installing piwik 1.5.1 in a debian lenny vps w/ apache 2.2 mod_fcgid - mod_security is not loaded.

during install, everything is green except tracker status.


403 
GET request to piwik.php failed. Try whitelisting this URL from mod_security and HTTP Authentication.

apache error.log shows:


client denied by server configuration: /var/www/piwik/public_html/piwik.php, referer: http://piwik.site.com/

access.log shows:


"GET /piwik.php?url=http://example.com HTTP/1.1" 403

Standard site definitions: here is the relevant extract from virtualhost file:


<IfModule mod_fcgid.c>
    SuexecUserGroup piwik piwik
    Include /etc/apache2/common.d/fcgid
    <Directory /var/www/piwik/public_html>
      Options +ExecCGI +FollowSymLinks
      AllowOverride None
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/piwik/php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

and the public_html directory & files are chown’ed properly.

Suggestions on how to fix?


#2

problem related to internal security settings.

added

<Files “piwik.php$”>
Order Allow,Deny
Allow from all

and piwik.php now tracks properly.


#3

Hi,

I have the same problem. Where do I need to install this code?

Still learning… not yet there. :wink:


(Matthieu Aubry) #4

IF you have the same message, you might have mod_security enabled, check out this faq: Troubleshooting - Analytics Platform - Matomo


#5

I have the same problem and I don’t have mod_security installed. Which file did you edit ?


#6

Put this code:
<Files “piwik.php$”>
Order Allow,Deny
Allow from all

Inside /etc/apache2/sites-available/000-default.conf (this is for Ubuntu). Don’t forget to reload/restart Apache.