Import logs replay tracking "successful," but no data (DID run archiving script)

Long story short, I imported an access log file & it was “successful,” but the data isn’t showing up even though I ran the archiving script (and that had no errors).

Did I run something incorrectly? Next debugging steps? I’m trying to avoid “importing it again” until I know what went wrong so I don’t get duplicated data by accident :slight_smile:

Thanks to anyone taking the time to read this!

More Details

Edit - Potentially important background info: unfortunately I am currently using an older version of Matomo (3.14.1). (This log import is actually part of our roadmap to upgrade to 4.2.1! :+1:)

Import Command

I imported an access log file (pre-filtered to only include requests between 03-31-21 and 04-02-21):

./misc/log-analytics/ --url=https://{my matomo URL} --replay-tracking ./tmp/logs/access-log-replay_03-31-21_to_04-02-21.log --replay-tracking-expected-tracker-file=tracker.php

Import Output

Logs import summary

    1353 requests imported successfully
    0 requests were downloads
    979 requests ignored:
        0 HTTP errors
        0 HTTP redirects
        974 invalid log lines
        0 filtered log lines
        0 requests did not match any known site
        0 requests did not match any --hostname
        5 requests done by bots, search engines...
        0 requests to static resources (css, js, images, ico, ttf...)
        0 requests to file downloads did not match any --download-extensions

Website import summary

    1353 requests imported to 16 sites
        16 sites already existed
        0 sites were created:

    0 distinct hostnames did not match any existing site:


Processing your log data

    In order for your logs to be processed by Matomo, you may need to run the following command:
     ./console core:archive --force-all-websites --force-all-periods=315576000 --force-date-last-n=1000 --url='https://{my matomo URL}'

Archiving Script Command

Then I ran the archiving script manually, pretty much copy/pasted the command from the import output:

./console core:archive --force-all-websites --force-all-periods=315576000 --force-date-last-n=1000 --url='https://{my matomo URL}

Missing Data

According to the importer script output, I should have ~1353 new actions for those days, right? (Across 16 sites.) Or at least something close to that.
Yet my “All Websites” page shows only 443 actions total for 4/1/21 alone, even after running the archiving script multiple times.

Debugging attempts

  • Tried the import command w/ --dry-run --debug --debug, but only info there was about the 979 “ignored requests” (which aren’t a problem).