Images breaking inside iframe widgets?


#1

Hello there,

When im logged in to piwiks backend the images show just fine in the iframe widget on anohter page (im using the token code) but when i logout they disapear?

Is there i way this can be fixed? Please help.


(Matthieu Aubry) #2

Known bug: Dashboard & Sparklines should work when embedded with token_auth · Issue #1353 · matomo-org/matomo · GitHub


#3

Thanks for the reply, but the patch didn’t solve my problem…

Anyone else?


#4

I am using the dashboard iframe with Piwik 1.12. The dashboard has the user’s token_auth, but the images being retreived for the goals overview widget does not use it as a parameter.

Is this still an open issue?


#5

Anybody else seeing this?


(Matthieu Aubry) #6

Update to 2.0 beta : 301 Moved Permanently

where this bug should be fixed!


#7

I upgraded to Piwik 2.0-b2. Unfortunately, this has not solved the issue.

Also, I am seeing a couple display issues within the embedded dashboard.


(Matthieu Aubry) #8

Thanks for the reports!

I fixed the encoding in live widget at: Adding missing |raw to money metrics to avoid double encoding · matomo-org/matomo@abe8ba1 · GitHub

the other full screen menu bug will be fixed as part of: Regression: full screen embed dashboard shows Menu behind calendar · Issue #4234 · matomo-org/matomo · GitHub

Sparklines not loading: fixed in Fixes #4264 When embedding the custom dashboard using &token_auth, ap… · matomo-org/matomo@4f1128e · GitHub

if you find more please let me know


#9

Awesome, thanks a lot matt!