IDSite is missing - cannot ad new websites


#1

Hi all,

i searechd all forums regarding this issue looking for help without success. So now i am trying it here and kindly ask for your help. Piwik is running since ages now for our websites with great success. We already update it automatically without any problem so far.

Today i wanted to add another website to monitor bt this failed. I had got above mentioned errror and could not add the page.

Dashboard : all common links worked but when i try to go to the submenu “websites” same error appears. Instead a fragmented part of the homepage where piwik is hosted appears - Screenshot enclosed.

index.php Piwik is secured by htaccess. Disabeling the htaccess did not work

different Browser - same result

deleted all files in tmp as per Piwik troubleshooting advise - same result

in the search enginges I found an advise that soemetimes worpress causes this error - but we dont work with wordpress.

updated today to latest beta version - problem still the same.

Does anyone have an idea what to do? I am not a php specialist th4 apologise for the rookie explanation - thanks for any help - it is urgent.

Dirk


#2

uploaded piwik today manually, checked different browsers and finally updated to 2.10.RC1 - no change yet. All seems to run correctly but still it is impossible to add new websites. Appreciate any help please. Thanks a lot.


#3

Would be thankful for any suggestions.


(Matthieu Napoli) #4

The error seems to be because there is no “idSite” URL parameter. Try to go on the dashboard, check that there is an idSite in the URL and try to go back to the settings: is the idSite still here? If not, try adding it manually to see if it temporarily fixes the problem.

Are you logged in with an admin/super user account ?


#5

thanks for your reply and help.

I think it is always there. The module is being called this way:

/piwik/index.php?module=SitesManager&action=index&date=today&period=day&idSite=1

And all other modules are working same way. IT is just the SitesManager module which doesnt work.

And yes - i am logged in with the admin account. This causing that i cannot add any new pages.


#6

updated to RC 3 - just to give it a try - but no change yet. The problem still remains the same.
thanks for any recommendation. dn


#7

@all - Thanks to Steve from the Piwik Team this problem is solved.

It had to do with the rewrite conditions in the htaccess file. More details you can find in the german forum or directly from Steve.
Thanks to the team for your support. We will continue supporting Piwik as well.
brgds
dirk