I found the way to fix the pclzip_err_bad_format issue


(Steven Lee) #1

Piwik is really great software, but from 0.45, the automatically update does work any more, it is really a big issue.
and today I found it is the bug of PclZip, so please update the PclZip library to the last version, and for the user who has install the Piwik, please following the article to update PclZip,
blog.rubypdf.com/2009/12/15/how-to-fix-pclzip_err_bad_format-issue-when-automatically-update-piwik/
How to fix pclzip_err_bad_format issue when automatically update Piwik

btw, had better Piwik team update PclZip first, or after we update our Piwik, the PclZip library will be replaced with older version again.

PS.
this forum does insert link, so I have to remove http, but you can copy and past the link to the browser to find the tutorial.


(vipsoft) #2

Thanks Steven!


(Steven Lee) #3

you are welcome, thanks for your great software.


(nicochto) #4

Additional note: I first needed to log out / log back in Piwik for this workaround to work. Thanks for this!


(DazzlinDonna) #5

Woot! Thank you! That solved my problem. I’ve finally been able to update automatically again. Yay!


(klktrk) #6

[quote=Steven Lee @ Dec 15 2009, 04:31 AM]Piwik is really great software, but from 0.45, the automatically update does work any more, it is really a big issue.
and today I found it is the bug of PclZip, so please update the PclZip library to the last version, and for the user who has install the Piwik, please following the article to update PclZip,
blog.rubypdf.com/2009/12/15/how-to-fix-pclzip_err_bad_format-issue-when-automatically-update-piwik/
How to fix pclzip_err_bad_format issue when automatically update Piwik[/quote]

To All: this problem still exists in later versions of Piwik, and with the latest version of PclZip. Today I just tried to auto update from piwik 0.6.1 to 0.6.2 and got the dreaded error. I checked my PclZip library version (2.8.2), the latest available.

So I guess we’re stuck with manual updates for now.