HTTP 500 after update from 2.8.3 to 2.9.1


#1

I get HTTP 500 Internal Server Error after updating from 2.8.3 to 2.9.1.

As update process suggested me to execute in shell “php /path/to/piwik core:update”, I did. After I confirmed executing SQL Queries to add/update some tables, process ended successfully. But my browser shows empty page, and curl -v says “Internal Server Error”. Any suggestions to fix problem?


(Matthieu Aubry) #2

Hi there, please check your server error log ?


#3

Matt, there is no error messages in error_log.

Uhh, I executed these commands:


# php /opt/stats/piwik/console core:clear-caches

******************
  Caches cleared  
******************

# php /opt/stats/piwik/console core:run-scheduled-tasks

****************************
  Scheduled Tasks executed  
****************************



Awesome!
Then piwik opened normally, I will watch them few future days for changes in working.


(Tassoman) #4

Also take care of file attributions in filesystem. Maybe webserver use wasn’t unable to modify them after being substituted by root, I always run a


chown www-data:www-data .

each time I do an update


#5

Thanks, guys, maybe there was problem with a permissions and Piwik’s cache. Problem solved.


#6

im receiving an error since the update, and a blank screen in chrome and a 500 internal server error in IE11.

this is my error from my server error log: [04-Dec-2014 15:37:00] PHP Warning: Unexpected character in input: ‘’ (ASCII=92) state=1 in /…/example/public_html/analytics/index.php on line 40
[04-Dec-2014 15:37:00] PHP Parse error: syntax error, unexpected T_STRING in /…/example/public_html/analytics/index.php on line 40

Also, I do not know how to “always run a…each time you do an update” as was mentioned earlier in this post.

please advise

Scott


(Matthieu Aubry) #7

HI Scott, see I get the error Warning: Unexpected character in input: '' (ASCII=92) state=1 - Analytics Platform - Matomo


#8

Hello, same here.

The log says:


09.12.2014 14:34:40 statistik.xxx.de [client xx.xxx.xx.x] PHP Fatal error:  Class 'ComposerAutoloaderInit62ff5c2fbc07919bd7f6c4f44af17302' not found in /mnt/webx/xx/x/xxxxxx/htdocs/piwik/vendor/autoload.php on line 7

Does FAQ 153 apply here?

Thanks in advance,
Daniel


#9

I get exactly the same error as Daniel W when upgrading from 2.8.0 to 2.9.1.

Not sure where to look to resolve this…

Adam.


#10

Hey, have a look here:

http://forum.piwik.org/read.php?2,122534

I really don’t know why I spammed more than one thread … soryy