How to exclude own IP from count?


(quixote) #1

I can’t seem to find a way to exclude my own IP from the piwik stats. How do I do that? I’m using piwik o.4.5.


(vipsoft) #2

It’s on the proverbial TODO list. Look in Trac…there are some community contributions in tickets #42 and #43.


(quixote) #3

Ah. I see. I’ll go have look at those, and add my bit. Meanwhile, I’ll just check my own sites as rarely as curiosity allows. style_emoticons/<#EMO_DIR#>/biggrin.gif


(quixote) #4

The screen to login or register at the Trac site doesn’t seem to work for me (Firefox 3.5.5, cookies on, javascript on, running on ubuntu). The BlockingCookie.php sounds exactly right, but I have a dumb question: how do I install it? Just put it in piwik’s “plugins” directory? Do something else? There’s no hint at the Trac site…


#5

When i extract the archive, all i get is a file named “dummy”.


(ChrisGt) #6

Hello Forum,
this is what i do:
1 create a cookie.php file in your Homedir and load it with your browser:

<?php // Prüfen if (!$_COOKIE[notMeCountPiwik]) { // Cookie erzeugen setcookie("notMeCountPiwik","ja",time()+60*60*24*1000,"/"); echo "Cookie wurde gesetzt!"; } else { echo "Cookie ist bereits gesetzt" echo $_COOKIE[notMeCountPiwik]; } ?>

this will set the cookie.

2
insert the tracking tag in php like that:

<?php // Prüfen if (!$_COOKIE[notMeCountPiwik]) { ?>

<?php } ?>

if you load your cookie.php from www.site.we/cookie.php,
and your site from site.we, this will not work. But you can set the cookie once more (whithout www.)


(rschilt) #7

Quixote,

I have included a simple “if” statement when running the Piwik tracking code to exclude any logged in user:

if ( !is_user_logged_in() ) { ?>

<! bla bla bla… -->

<?php } Robert PS. I'm running Wordpress

(synn) #8

[quote=rschilt @ Dec 10 2009, 09:10 PM]Quixote,

I have included a simple “if” statement when running the Piwik tracking code to exclude any logged in user:

if ( !is_user_logged_in() ) { ?>

<! bla bla bla… -->

<?php } Robert PS. I'm running Wordpress[/quote] I tried this but it is not working for me. I'm using wordpress 2.8.6 version.

#9

[quote=ChrisGt @ Dec 10 2009, 05:06 PM]Hello Forum,
this is what i do:
1 create a cookie.php file in your Homedir and load it with your browser:

<?php // Prüfen if (!$_COOKIE[notMeCountPiwik]) { // Cookie erzeugen setcookie("notMeCountPiwik","ja",time()+60*60*24*1000,"/"); echo "Cookie wurde gesetzt!"; } else { echo "Cookie ist bereits gesetzt" echo $_COOKIE[notMeCountPiwik]; } ?>

this will set the cookie.

2
insert the tracking tag in php like that:

<?php // Prüfen if (!$_COOKIE[notMeCountPiwik]) { ?>

<?php } ?>

if you load your cookie.php from www.site.we/cookie.php,
and your site from site.we, this will not work. But you can set the cookie once more (whithout www.)[/quote]

This might work for web sites in PHP but not with websites that are just simple XHTML (with CSS2 and JS). The PHP tag wont be parsed by the server and i wont tell the server to parse all files with PHP; that could cause unwanted load.


(quixote) #10

I just checked back in after a hiatus, and see all the answers. Thanks! I’ll try the different methods. Luckily, I’m on a php site style_emoticons/<#EMO_DIR#>/smile.gif, but it’s also wordpress 2.8.6 style_emoticons/<#EMO_DIR#>/sad.gif. I’ll see how I go. Thanks again for the help.


(frankb) #11

I attached the suffix .tar (as it is a .tar.gz-file) to the dummy-file (dummy.tar) and extracted the file. So there is the folder “BlockingCookie”.

For instructions to install the plugin see: forum.piwik.org/index.php?showtopic…&#entry4117
Generally:

  1. copy folder “BlockingCookie” to piwik/plugins/ and
  2. activate plugin (Piwik: settings>Plugins)

But for me this does not work at all. My own visits are still recorded, while the cookie is set.

Edit: Seems to work now (Plugin must state “You will not be tracked.”). I don’t know why.