How to disable the LanguagesManager plugin?


#1

global.ini.php says


; if you want all your users to use Piwik in only one language, disable the LanguagesManager                                                                          
; plugin, and set this default_language (users won't see the language drop down)
default_language = en

how exactly do I disable the LanguagesManager plugin? I tried removing it from config.ini.php but it keeps reappearing.

regards


#2

goole may help youhttp://www.infoocean.info/avatar2.jpg


#3

not really

anyone please?


(Matthieu Aubry) #4

Go to Settings > Plugins and disable the plugin


#5

it just doesn’t appear in the plugin list. i tried editing config.ini.php by hand but LanguagesManager plugin reappears in PluginsInstalled[] = “LanguagesManager” as soon as I visit my piwik installation


(Matthieu Aubry) #6

Yes because it’s installed indeed, but not enabled


#7

fair enough,

that doesnt’ explain why it doesn’t appear on the settings > plugins page with an inactivate link though

i’m running 1.7.2-rc4 for the record


#8

if someone manages to disable the language manager and force the language to be english only, please let me know

thx in advance


#9

bump

i’m running revision 6207, still no way to disable language manager


(vipsoft) #10

Edit core/PluginsManager.php, and remove LanguagesManager from the $pluginToAlwaysActivate array.


#11

now I’m getting Language file ‘’ not found.

guess it can’t be disabled after all…


#12

On the new version, you only need to edit the file global.ini.php in piwik/config.

Set the default_language accordingly to the name of the language files at the lang folder.
And also set the parameter enable_language_to_country_guess to 0
For language pt_BR:

default_language = pt-br

enable_language_to_country_guess = 0


(jkdcdlly) #13

hello gpakosz,how solved that your problem?