Help: Login Issue


(Rakesh) #1

Hi,
I have a custom install of piwik, untill day before yesterday it was working fine. Yesterday when I tried to login using the superuser account. Its not accepting my login/password and redirects me back to login page everytime.

  1. I tried changing my password, and tried with new password that I got in my mail. It didnt work with that also.
  2. I did a re-install by deleting the config.ini.php and used the old database it again didn’t work ?

Need help as to where should I look for the details of this issue?

  1. Is there any logfile where I can check first ?
  2. what could be the possible reasons for the same !

Any quick help will be really appreciated.

Thanks in advance

PS: I am using piwik 0.4.2

RK


(Matthieu Aubry) #2

You will find a MD5 hash of your super user account, as well as your login, in the file config/config.ini.php

you can create a md5 hash for a new password you wish to use and replace in the file.


(psychobilly) #3

Hi,

same problem. I tried your advice and created a D5 hash and entered it as password inthe config.ini.php file.
Nothing changes, still can’t get no access to my data.

Has something changed the last days? (serverside)


(vipsoft) #4

Check to make sure that you’re connecting to the right Piwik server if you have more than one instance.

What do you mean by “Has something changed the last days?” Does your custom install “update” via svn?


(psychobilly) #5

Hi,

no didn’t updated anything.
And it’s getting stranger!
I can login with my standard account with the IE 8.0 (where I can’t see the visitor graph style_emoticons/<#EMO_DIR#>/dry.gif ). But can’t do it with the Firefox 3.5.
I cleared the cache and deleted all cookies which didn’t help. So I created a second superuser account which worked for aprox 1 week until today. Fiefox won’t let me in again.
Ordered a new password - no success.
Created a new md5 hash of my password put it in the config file - no success.

This started a few weeks after the last generall update of piwik, from one day to another.
Do you think it could be a browser problem or something serversided of my provider?

And is the username case senitive? It always changes my username from a********* to A*********.
One thing I did today was to login with that account from another pc. But I don’t think that this could be the reason, doesn’t it?

Anyone else got the same problem? I’m really running out of ideas…


(vipsoft) #6

If you haven’t configured mail() on your server, you won’t receive the new password via email.

This sounds like a browser problem. Try disabling extensions, ‘remember what I enter in forms’, ‘correct as I type’, and ‘remember passwords’ in your browser.


(psychobilly) #7

Many thanks!
You brought me on the right track. I deleted all entries in the login form. Those which pop up when you click on the username field. And re-entered my data.
Open sesame - I’m inside.

So it must be a firefox conflict. Good to know… style_emoticons/<#EMO_DIR#>/wink.gif