Have Piwik ignore Google Analytics get parameters


#1

First off, I love the Piwik. 2.0 is awesome!

I am using Piwiki and Google Analytics on a multidomain site. GA handles this by using get parameters to ignore outlinks (fun/?_ga=###). Piwik treats these as different sites based on their different url. Is there anyway for Piwik to ignore these get parameters are track it as the same page (fun/)?

Please advise.
Thanks!


(Matthieu Aubry) #2

I didn’t understand what you ask. Can you please try again to explain what is not working, what you expect to work, and/or what you try to achieve?


#3

I am using both Google Analytics and Piwik on my multidomain website. Google Analytics handles this by using linker parameters. GA adds query parameters to all the URLs that point to the domains that are part of the multidomain site. So when you navigation from one domain to the other the link has something this parameter appended: “_ga=1.182119591.1441315536.1362115890410”. This then makes each cross domain visit show up as an individual page. Is there a way to have Piwik ignore this pattern or must I modify the javascript that sends the data to Piwik. To fix the urls already sent would I just modify the name column in piwik_log_action? Also, as an aside, the values in the blob table are not human readable, is this supposed to be the case?
Thanks!


(Matthieu Aubry) #4

Go to Settings > Websites > go down to Excluded URL Parameters, and add a new param to exclude _ga


#5

Thanks!

It wasn’t a retro active fix. I just modified the name column in piwik_log_action to removed the parameter from the url. Then I deleted the archive datas to re-create the database cache with good data.


(Matthieu Aubry) #6

Good stuff. Btw we also hope to support cross domain tracking in the future, see ticket http://dev.piwik.org/trac/ticket/2211