Goal tracking not working

I installed Piwik with no problem. I added the default javascript tracking to my wordpress site and it tracks visitors very nice. The problem is with goals.
My hosting is hostgator and I already dealt with the mod_secure issue.

I have a site that has an article free-dupe, so the address is like

I created 3 goals:

  1. When visitor visits a site and address contains free-dupe, no revenue
  2. When visitor visits a site and address is exactly http://domain.com/free-dupe/, $1
  3. When visitor visits a site and address contains Wowbootybay.com, $1

None of these is tracked and I have a 10 sec update set in configuration. Please advise.

if you are testing yourself, goals are only triggered once per visit so your page views wouldn’t trigger it during your tests (after initial conversion). DO you still have the issue even after other visitors visited the page?

I have the same problem here. I have set up a few test goals and no conversions are showing.

Me too … Issue still prevalent after visitors enter the site.

I’ve tried using:

piwikTracker.trackGoal(1); // logs a conversion for goal 1

To manually trigger a goal and that hasn’t worked either.

There is a known bug with regex: Goal matching regex - test for regression · Issue #1991 · matomo-org/matomo · GitHub

but manual goal tracking with trackGoal should definitely work. Is your log_conversion table empty?

Sure is. The fields look right just no data.

Also have the same problem, no goal is recorded. The log_conversion table doesn’t shows any entries since January. That’s real bad.
Hope some one of you may find the solution fast.

I have run into same situation.
After creating the goals, I was expecting it to get some resutls, but it does not.
The only difference is that I use import_logs.py to populate all the data in piwik.

I have followed the How to goals and I believe its pretty straight forward.
There are zero entries in piwik_log_conversions table.

Any clues?

Thanks and Regards,

by the way I am using piwik 1.8.4

There is no known bug for Goal Tracking. So maybe you mis-configured goals or maybe there’s another problem ? let us know more info

Thanks for the response Matt. It was my understanding problem.

I imported the logs first and then created goals, assuming that there will some kind of batch job, which will update the goals for so far uploaded data. After looking at sources, I realized that the goals are updated as the events are processed and there is batch processing of any sort.

Once I uploaded new log entries the goals data updated as expected.

Thanks again.