Getting Invalid idSite error


#1

Hi Guys,

I just installed Pikwik to track my eBay store.

I’ve uploaded the tracking image to my store and got no data.

I’ve enabled the Debug mode and I’ve got this error:


Invalid idSite: '0'

And before the error it seems to be correct:


DEBUG Piwik\Common[2014-05-08 13:05:57] [efa33]   'idSite' => '2',
DEBUG Piwik\Common[2014-05-08 13:05:57] [efa33]   'rec' => '1',

How can I fix this?

Thanks,


#2

UPDATE:

In my system check I get this notice:
[quote=“Using LOAD DATA INFILE will greatly speed Piwik’s archiving process up. To make it available to Piwik, try updating your PHP & MySQL software and make sure your database user has the FILE privilege.
If your Piwik server tracks high traffic websites (eg. > 100,000 pages per month), we recommend to try fix this problem.
Error:
Try #1: LOAD DATA INFILE : SQLSTATE[28000]: Invalid authorization specification: 1045 Access denied for user ‘XXXX’@’%’ (using password: YES)[28000]”]
[/quote]

But as I don’t have plans to get as many as 100 000 visitors, I’m igonirng that at the moment. Can it be the cause of the problem?

Thanks


(Matthieu Aubry) #3

you should use &idsite= and not &idSite= (notice the case difference)

If you saw &idSite= somewhere in the doc let me know as we need the user guides to be correct :slight_smile:


#4

Hi, yes this error is in configuration.

When I copy the image link for tracking, the idsite is with S in uppercase.

Thanks for pointing that. Now it works.


(Matthieu Aubry) #5

Thanks I fixed it in Image tracker displays wrong code: idSite= but idsite= should be used instead · Issue #5131 · matomo-org/matomo · GitHub


#6

The idSite parameter is used in some core functions and the documentation:

Documentation:
http://developer.piwik.org/guides/controllers#generating-output

Core Menu: