General error: 126 Incorrect key file for table '/tmp/#sql_42.MYI';


(bigbabou) #1

Hi piwikians,

while this might be a general mysql error, it roughly affects my in-production piwik 0.4.1 that does not show any useful data anymore. server was unchanged since last update, and some days after update it started showing me:

Of course i tried mysqlrepair and all that, and i got it to work yesterday (but only for that day). But the last days of data could still not be shown.

to re-create archive i went for

always_archive_data_period = 1; always_archive_data_day = 1;
but the archive.sh script only provides the line you could read above.

Anyone ran into that problem? All other databases on this server work as intended.

thanks in advance,
bigbabou

edit:
main problem to me is that piwik currently does not collect any data. i only get No data for this tag cloud/table if i select a date newer than the incident. hope i don’t need to restart from NULL.


(bigbabou) #2

ok, the system is nominal. caused by a too small /tmp partition on a vserver guest system. just raise it and rerun ./archive style_emoticons/<#EMO_DIR#>/smile.gif