[gelöst]Piwik funktioniert scheinbar super, aber


#1

Hallo allerseits,

gestern habe ich Piwik installiert, es funktioniert bis auf ein Sache super. Wenn ich zu Einstellungen-> Benutzer oder Webseiten oder Plugins gehe bekomme ich folgende Meldung die ich hier im Forum posten soll.


Warning: include(/tmp/templates_c/%%47^478^478060D7%%UsersManager.tpl.php) [<a href='function.include'>function.include</a>]: failed to open stream: Datei oder Verzeichnis nicht gefunden in /libs/Smarty/Smarty.class.php on line 1263

Backtrace -->
#0 Piwik_ErrorHandler(2, include(/tmp/templates_c%%47^478^478060D7%%UsersManager.tpl.php) [<a href='function.include'>function.include</a>]: failed to open stream: Datei oder Verzeichnis nicht gefunden, /libs/Smarty/Smarty.class.php, 1263, Array ([this] => Piwik_Smarty Object ([template_dir] => Array ([0] => //pi/plugins,[1] => /mnt/web8/61/25/5786225/htdocs/db/pi/themes/default,[2] => /themes),[compile_dir] => /mnt/web8/61/25/5786225/htdocs/db/pi/tmp/templates_c,[config_dir] => configs,[plugins_dir] => Array ([0] => /core/SmartyPlugins,[1] => /libs/Smarty/plugins),[debugging] => ,[error_reporting] => 6143,[debug_tpl] => ,[debugging_ctrl] => NONE,[compile_check] => 1,[force_compile] => ,[caching] => 0,[cache_dir] => /tmp/cache,[cache_lifeti...<span id="languageSelection" style="display:none;position:absolute"><form action="index.php?module=LanguagesManager&action=saveLanguage" method="get"><select name="language"><option value="de">Deutsch</option><option href='?module=Proxy&action=redirect&url=http://piwik.org/translations/'>Über Piwik Übersetzungen</option><option value="am" title="አማርኛ (Amharic)">አማርኛ</option><option value="ar" title="العربية (Arabic)">العربية</option><option value="be" title="Беларуская (Belarusian)">Беларуская</option><option value="bg" title="Български (Bulgarian)">Български</option><option value="ca" title="Català (Catalan)">Català</option><option value="cs" title="Česky (Czech)">Česky</option><option value="da" title="Dansk (Danish)">Dansk</option><option value="de" title="Deutsch (German)">Deutsch</option><option value="el" title="Ελληνικά (Hellenic)">Ελληνικά</option><option value="en" title="English (English)">English</option><option value="es" title="Español (Spanish)">Español</option><option value="et" title="Eesti keel (Estonian)">Eesti keel</option><option value="eu" title="Euskara (Basque)">Euskara</option><option value="fi" title="Suomi (Finnish)">Suomi</option><option value="fr" title="Français (French)">Français</option><option value="gl" title="Galego (Galician)">Galego</option><option value="he" title="עברית (Hebrew)">עברית</option><option value="hu" title="Magyar (Hungarian)">Magyar</option><option value="id" title="Bahasa Indonesia (Indonesian)">Bahasa Indonesia</option><option value="is" title="Íslenska (Icelandic)">Íslenska</option><option value="it" title="Italiano (Italian)">Italiano</option><option value="ja" title="日本語 (Japanese)">日本語</option><option value="ka" title="ქართული (Georgian)">ქართული</option><option value="ko" title="한국어 (Korean)">한국어</option><option value="lt" title="Lietuvių (Lithuanian)">Lietuvių</option><option value="nb" title="Norsk (bokmål) (Norwegian Bokmål)">Norsk (bokmål)</option><option value="nl" title="Nederlands (Dutch)">Nederlands</option><option value="nn" title="Nynorsk (Norwegian Nynorsk)">Nynorsk</option><option value="pl" title="Polski (Polish)">Polski</option><option value="pt-br" title="Português brasileiro (Brazilian Portuguese)">Português brasileiro</option><option value="pt" title="Português (Portuguese)">Português</option><option value="ro" title="Română (Romanian)">Română</option><option value="ru" title="Русский (Russian)">Русский</option><option value="sk" title="Slovensky (Slovak)">Slovensky</option><option value="sq" title="Shqip (Albanian)">Shqip</option><option value="sr" title="Srpski (Serbian)">Srpski</option><option value="sv" title="Svenska (Swedish)">Svenska</option><option value="te" title="తెలుగు (Telugu)">తెలుగు</option><option value="th" title="ภาษาไทย (Thai)">ภาษาไทย</option><option value="tr" title="Türkçe (Turkish)">Türkçe</option><option value="uk" title="Українська (Ukrainian)">Українська</option><option value="zh-cn" title="简体中文 (Simplified Chinese)">简体中文</option><option value="zh-tw" title="繁體中文 (Traditional Chinese (Taiwan))">繁體中文</option></select><input type="submit" value="go" /></form></span><script type="text/javascript"> piwik.languageName = "Deutsch"; $(document).ready(function() { $("#languageSelection").fdd2div({CssClassName:"formDiv"}); $("#languageSelection").show(); $("#languageSelection ul").hide(); });</script></span>,[_order] => 30,[_hasSubmenu] => )),[currentAdminMenuName] => UsersManager_MenuUsers,[debugTrackVisitsInsidePiwikUI] => 0,[isSuperUser] => 1,[menu] => Array ([UsersManager_MenuUserSettings] => Array ([_url] => Array ([module] => UsersManager,[action] => userSettings),[_order] => 1,[_hasSubmenu] => ),[UsersManager_MenuUsers] => Array ([_url] => Array ([module] => UsersManager,[action] => index),[_order] => 3,[_hasSubmenu] => ),[SitesManager_MenuSites] => Array ([_url] => Array ([module] => SitesManager,[action] => index),[_order] => 5,[_hasSubmenu] => ),[CoreAdminHome_MenuGeneralSettings] => Array ([_url] => Array ([module] => CoreAdminHome,[action] => generalSettings),[_order] => 6,[_hasSubmenu] => ),[CorePluginsAdmin_MenuPlugins] => Array ([_url] => Array ([module] => CorePluginsAdmin,[action] => index),[_order] => 7,[_hasSubmenu] => )),[currentModule] => UsersManager,[userLogin] => aiFaisha6udue4shee7oob9Am,[sites] => Array ([0] => Array ([idsite] => 1,[name] => moenchmuehle,[...#1 Smarty::fetch() called at [/mnt/web8/61/25/5786225/htdocs/db/pi/libs/Smarty/Smarty.class.php:1263]#2 Smarty->fetch(/plugins/UsersManager/templates/UsersManager.tpl) called at [/core/View.php:172]#3 Piwik_View->render() called at /plugins/UsersManager/Controller.php:92]#4 Piwik_UsersManager_Controller->index()#5 call_user_func_array(Array ([0] => Piwik_UsersManager_Controller Object ([] => UsersManager,[] => 2011-03-20,[] => Piwik_Date Object ([] => 1300650282,[] => UTC),[] => 1,[] => Piwik_Site Object ([] => 1)),[1] => index), Array ()) called at [/core/FrontController.php:125]#6 Piwik_FrontController->dispatch() called at [/index.php:57]

Ich habe zwar auch schon hier im Forum und bei google gesucht, aber nichts passendes gefunden, wie ich meine.

Kann mir bitte jemand helfen. Alles andere funktioniert anscheinend.

Viele Grüße aus Hessen


(Peterbo) #2

Bitte sicherstellen, dass bei der Installation alle Dateien erfolgreich angelegt wurden.


#3

Hallo mediaproweb,

ich habe eben die Verzeichnisse mit xxdiff verglichen, anscheinend wurden einige neue .htaccess angelegt. Ansonsten ist, glaube ich, ist alles da. Die Analyse an sich funktioniert auch, nur einige Einstellungen kann ich nicht vornehmen. Ob das vielleicht an meinem Provider, Strato, liegt oder ob es ein Rechte Problem ist? Ich versuche weiterhin eine Lösung zu finden, wenn mir jemand einen Tip geben könnte wäre ich sehr dankbar.

Viele Grüße aus Hessen.


#4

Hallo,

nach der Ansicht der Log-Datei habe ich festgestellt, das für das Verzeichnis /tmp/templates_c/ die Rechte nicht richtig gesetzt waren. Nach der Korrektur sind die Fehlermeldungen weg, allerdings sind dafür die entsprechenden Seiten weiß. Immerhin ein kleiner Fortschritt. Jetzt überlege ich die Dateien per FTP nochmal auf den Server zu laden. Könnte das helfen? Und was ist dann mit meinen bisherigen Analysen, sind die weg? Wenn ich das richtig verstanden habe reicht ein Backup und wiederherstellen der config.ini.php um die alte Konfiguration zu behalten.

Viele Grüße aus Hessen.


(Thomas Seifert) #5

Steht im PHP log nichts weiter wegen der weißen Seiten?


#6

Ein PHP Log finde ich jetzt nicht, auch diesen Security Registerreiter habe ich nicht in meiner Installation. Ist vielleicht etwas unvollständig.

Gruß


#7

So, ich habe es hin bekommen. “Schwitz” . Nach den Fehlermeldungen habe ich zuerst alle php Dokumente die nicht erreichbar waren notiert. Nach dieser Liste habe ich alle diese Dokumente im Verzeichnis template_c gelöscht und Piwik neu aufgerufen, vorher habe ich, wie schon gesagt die Rechte am Verzeichnis template_c angepasst… Dann ging es wieder. Jetzt konnte ich auch an die Plugins und SecurityInfo aktivieren.

Ich danke Euch für Eure Mühe.

Gruß

Matthias