Forced SSL Connection error invalid and causes bugs

Dear Matomo!

" We recommend using Matomo over secure SSL connections only. To prevent insecure access over http, add force_ssl = 1 to the General section in your Matomo config/config.ini.php file."

We are behind an SSL-offloading proxy server and don’t need this to be set. As such, this error is invalid. There is no way for outside non-SSL traffic to reach our servers!

Even worse, to upload the logs, having set this value, one would have to go over an inefficient and outside SSL connection for this to work. This does not make sense and is illogical and makes uploading impossible as the program bugs.

Please fix this false and annoying warning. Thanks
Dennis

Generally, SLL is also recommended in local networks. Don’t forget that Matomo can track / store personal data and also some sensitive marketing data. Then the connections should always be secured.

@Philippe. Thanks for your reply but this error message is invalid and incorrect for us.
[1] Everything non-SSL behind the proxy is only accepted by 127.0.0.1, and as such, any client - internal or external - can only access our stacks via the SSL proxy.
[2] What is really annoying is that the log import breaks with this setting!!!
[3] GDPR does not allow us to use any trackers; we only do log imports.

We need a way to suppress this invalid error message.

Still waiting for an answer…

You can create an issue in the Matomo GitHub repo

I thought the point is to report such bugs here, and that, there is a possible solution here.