Flash not showing in firefox


(hanseate) #1

i have got the same problem with flash.
the graphs are not showing, but flash for firefox is installed and works on other websites.

in internet explorer, piwik flash is working well.

this is the error message:

Displaying Graphs in Piwik requires Flash >= 9.0.0. More information about displaying graphs in Piwik.
" + Control.OFC.image(src) + "

Um das Bild auf dem Computer zu speichern, einen Rechtsklick auf das Bild machen und â��Bild speichern unter…" auswählen.
"); } }; if (typeof Control == “undefined”) { var Control = {OFC: OFC.jquery}; } // By default, right-clicking on OFC and choosing “save image locally” calls this function. function save_image() { OFC.jquery.popup(“VisitsSummarygetEvolutionGraphChart_swf”); } swfobject.embedSWF( “libs/open-flash-chart/open-flash-chart.swf?piwik=0.4.5”, “VisitsSummarygetEvolutionGraphChart_swf”, “100%”, “150”, “9.0.0”, “libs/swfobject/expressInstall.swf”, { “data-file”:“index.php%3Fmodule%3DVisitsSummary%26action%3DgetEvolutionGraph%26columns%255B%255D%3Dnb_visits%26idSite%3D1%26period%3Dday%26date%3D2009-10-10%2C2009-11-08%26viewDataTable%3DgenerateDataChartEvolution”, “loading”:“Laden…” }, { “allowScriptAccess”:“always”, “wmode”:“opaque” }, {“bgcolor”:"#FFFFFF"} );

what can i do.
FF3.5.5, Flash 10.0 r32
the error console tells some things like “missing) after argument list, filter, cellspacing, font-weight, height, -moz-opacity, and margin-top”

thank you for your help


(hanseate) #2

with safari (4.0.2), the graphs do not work, too.

this error message appears:

Displaying Graphs in Piwik requires Flash >= 9.0.0. More information about displaying graphs in Piwik.
" + Control.OFC.image(src) + "

Um das Bild auf dem Computer zu speichern, einen Rechtsklick auf das Bild machen und â��Bild speichern unter…" auswählen.
"); } }; if (typeof Control == “undefined”) { var Control = {OFC: OFC.jquery}; } // By default, right-clicking on OFC and choosing “save image locally” calls this function. function save_image() { OFC.jquery.popup(“VisitsSummarygetEvolutionGraphChart_swf”); } swfobject.embedSWF( “libs/open-flash-chart/open-flash-chart.swf?piwik=0.4.5”, “VisitsSummarygetEvolutionGraphChart_swf”, “100%”, “150”, “9.0.0”, “libs/swfobject/expressInstall.swf”, { “data-file”:“index.php%3Fmodule%3DVisitsSummary%26action%3DgetEvolutionGraph%26columns%255B%255D%3Dnb_visits%26idSite%3D1%26period%3Dday%26date%3D2009-10-10%2C2009-11-08%26viewDataTable%3DgenerateDataChartEvolution%26columns%255B%255D%3Dnb_visits”, “loading”:“Laden…” }, { “allowScriptAccess”:“always”, “wmode”:“opaque” }, {“bgcolor”:"#FFFFFF"} );

flash is installed, the adobe test for flash is working.

[edit:
i reinstalled piwik, but the graphs are still not showing]

can you help?
i dont know what i can do

thx


(vipsoft) #3

I’ve only seen this problem with free web hosts that munge the response.

try svn or wait for 0.5 … we moved a lot of that JavaScript to a separate .js file.


(hanseate) #4

hello

i think i will wait for 0.5

(hoster is “unaxus”)

“shared hosting” or something? - i don`t know - less than 3euro/month

greets