Fehlermedlung bei Installation


(conmuc) #1

Hallo zusammen,
versuche gerade, piwik auf einem 1&1 Hosting Paket zu installieren. Alle Rechte auf 755. Beim Aufruf von www.domain.de/piwik kommt:

Unable to load plugin ‘API’ because ‘…/piwik/plugins/API/API.php’ couldn’t be found. You can manually uninstall the plugin by removing the line Plugins[] = API from the Piwik config file.
Backtrace:

#0 /…/piwik/core/PluginsManager.php(270): Piwik_PluginsManager->loadPlugin(‘API’)
#1 /…/piwik/core/PluginsManager.php(182): Piwik_PluginsManager->reloadPlugins()
#2 /…/piwik/core/FrontController.php(208): Piwik_PluginsManager->loadPlugins(Array)
#3 /…/piwik/index.php(59): Piwik_FrontController->init()
#4 {main}

Diese Datei api.php ist aber da. Was hat das zu bedeuten und wie komme ich weiter?
Danke


(conmuc) #2

Hallo nochmal,
habe das gelöst:
es lag am ftp-Programm, das alle Datei- und Verzeichnisnamen auf dem Remote-Server klein schreibt. Damit hiess dieses Verzeichnis api und nicht API etc. Deshalb auch die weiteren Fehlermeldungen als Folgefehler.
Lösung: durch ein anderes FTP-Programm gehts.
1und1 kann nichts dafür (der php5 Teil in der htaccess muss natürlich rein).