Fehler nach Upgrade


(Guido Drehsen) #1

ich habe Ende letzten Jahres in Matomo Webinterface auf das angebotene Update geklickt.
(Wir haben eine docker-compose Installation.)

Seitdem erhalte ich nun beim Aufruf diese Fehlermeldung:

Ihre Piwik Codebase läuft auf der alten Version 3.2.1 und wir haben erkannt, dass Ihre Piwik Datenbank bereits auf die neuere Version 3.7.0 aktualisiert wurde. Möglicherweise sind die Piwik Administratoren gerade daran, den Aktualisierungsprozess abzuschließen. Bitte versuchen Sie es in ein paar Minuten noch einmal. Falls dieses Problem weiterhin besteht, kontaktieren Sie bitte Ihren Piwik Administrator für Unterstützung.

ein erneuter docker-compose pull hat die Meldung bezüglich der Version etwas verändert und aus Piwik dann Matomo gemacht.

Ihre Matomo Codebase läuft auf der alten Version 3.6.0 und wir haben erkannt, dass Ihre Matomo Datenbank bereits auf die neuere Version 3.7.0 aktualisiert wurde. Möglicherweise sind die Matomo Administratoren gerade daran, den Aktualisierungsprozess abzuschließen. Bitte versuchen Sie es in ein paar Minuten noch einmal. Falls dieses Problem weiterhin besteht, kontaktieren Sie bitte Ihren Matomo Administrator für Unterstützung.

Wie kann ich das Problem beheben?
ssh root Zugriff auf unseren Server habe ich.


(Lukas Winkler) #2

Hallo,

Wie der Name schon sagt, hast du das Update auf 3.7.0 schon gemachst, verwendest aber die Matomo-Dateien von 3.6.0.

Ich würde somit empfehlen das docker-image für 3.7.0 zu verwenden. Ich bin kein großer Docker-Experte, aber anscheinend gibt es das schon: Docker Hub (unter der Annahme, dass du das offizielle Image verwendest)


(Guido Drehsen) #3

ich habe es gelöst bekommen. :wink:
Ich musste in der docker-compose.yml bei image es von piwik auf matomo ändern, dann hat sich der docker-compose pull die neueste Version gezogen.

services:
piwik:
image: piwik:latest
restart: unless-stopped

ändern in

services:
piwik:
image: matomo:latest
restart: unless-stopped