Fehler bei Update auf 2.1


#1

Hallo liebe Gemeinde.
Ich habe heute versucht das update von 2.03 auf 2.1 durchzuführen.
Leider gab es einen Fehler und nun steht mein Piwik still…
Ich poste den Text mal weiter unten. Kann mir dazu jemand helfen?
Bis jetzt sind alle Updates immer problemlos durchgelaufen. Leider ist mein englisch nicht das Beste, deshalb komme ich mit dem Parallelforum nicht ganz klar. Ich weiß auch nicht wonach ich gerade suchen sollte.
Ich bedanke mich schon jetzt für eure Hilfe!
Sollte auf ein englisches Forum/Thread verlinkt werden, dann werde ich mein bestes geben mich dort einzulesen. Eine Hilfe auf deutsch wär allerdings ein Traum.
Danke
Olli


There is an error. Please report the message (Piwik 2.1.0) and full backtrace in the Piwik forums

Notice: Undefined index: schema in /var/www/web3/html/sub/php/piwik/core/Db/Schema.php on line 113

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/var/www/web3/html/sub/php/piwik/core/Db/Schema.php:113]
#1 Piwik\Db\Schema->loadSchema(…) called at [/var/www/web3/html/sub/php/piwik/core/Db/Schema.php:131]
#2 Piwik\Db\Schema->getSchema(…) called at [/var/www/web3/html/sub/php/piwik/core/Db/Schema.php:249]
#3 Piwik\Db\Schema->hasTables(…) called at [/var/www/web3/html/sub/php/piwik/core/DbHelper.php:72]
#4 Piwik\DbHelper::isInstalled(…) called at [/var/www/web3/html/sub/php/piwik/plugins/CoreUpdater/Controller.php:340]
#5 Piwik\Plugins\CoreUpdater\Controller->doWelcomeUpdates(…) called at [/var/www/web3/html/sub/php/piwik/plugins/CoreUpdater/Controller.php:300]
#6 Piwik\Plugins\CoreUpdater\Controller->runUpdaterAndExit(…) called at [/var/www/web3/html/sub/php/piwik/plugins/CoreUpdater/Controller.php:270]
#7 Piwik\Plugins\CoreUpdater\Controller->index(…) called at [:]
#8 call_user_func_array(…) called at [/var/www/web3/html/sub/php/piwik/core/FrontController.php:521]
#9 Piwik\FrontController->doDispatch(…) called at [/var/www/web3/html/sub/php/piwik/core/FrontController.php:84]
#10 Piwik\FrontController->dispatch(…) called at [/var/www/web3/html/sub/php/piwik/index.php:62]


#2

Ja das Update war etwas problematisch. Andere hatten schon den selben Fehler.
Hier solltest du die Lösung (leider auf Englisch) finden:
http://forum.piwik.org/read.php?2,112677,112810

PS Solltest du es wirklich nicht verstehen, frag ruhig nochmal nach :wink:


#3

Super Danke…
Ich versuch mein Glück und sonst melde ich mich wieder…
Olli