Fatal error: Class 'Piwik_DataTable_Filter_AddColumnsProcessedMetrics' not found in /home/nite/public_html/piw/core/DataTable/Filter/AddColumnsProcessedMetricsGoal.php on line 18


(tom_taylor) #1

Hi

Upgraded to 1.5.1, and some plugins on my dashboard show the following error:

Fatal error: Class ‘Piwik_DataTable_Filter_AddColumnsProcessedMetrics’ not found in /home/nite/public_html/piw/core/DataTable/Filter/AddColumnsProcessedMetricsGoal.php on line 18

Also the actions tab shows the above error

When clicking on the UI Framework tab, i get the following error:

Fatal error: Class ‘Piwik_DataTable’ not found in /home/nite/public_html/piw/plugins/ExampleUI/API.php on line 77

Click on the Security tab in settings, i get the following error:

Fatal error: Class ‘Piwik_Http’ not found in /home/nite/public_html/piw/plugins/SecurityInfo/PhpSecInfo/Test/Application/php.php on line 34

Can someone please advise how to fix these issues, ive not seen them within the bugtracker?

Thanks

Tom


(tom_taylor) #2

Now added and fixed all issues on my instance of piwik and have included patches:

#2544 - Goals plugin on dashbaord Fatal error: Class ‘Piwik_DataTable_Filter_AddColumnsProcessedMetrics’ not found in /home/piwik/public_html/core/DataTable/Filter/AddColumnsProcessedMetricsGoal.php on line 18 · Issue #2544 · matomo-org/matomo · GitHub
Goals plugin on dashbaord Fatal error: Class ‘Piwik_DataTable_Filter_AddColumnsProcessedMetrics’ not found in /home/piwik/public_html/core/DataTable/Filter/AddColumnsProcessedMetricsGoal.php on line 18

#2545 - UI Framework Tab Fatal error: Class ‘Piwik_DataTable’ not found in /home/nite/public_html/piw/plugins/ExampleUI/API.php on line 77 · Issue #2545 · matomo-org/matomo · GitHub
UI Framework Tab Fatal error: Class ‘Piwik_DataTable’ not found in /home/nite/public_html/piw/plugins/ExampleUI/API.php on line 77

#2546 - Security Tab in Settings Fatal error: Class ‘Piwik_Http’ not found in /home/nite/public_html/piw/plugins/SecurityInfo/PhpSecInfo/Test/Application/php.php on line 34 · Issue #2546 · matomo-org/matomo · GitHub
Security Tab in Settings Fatal error: Class ‘Piwik_Http’ not found in /home/nite/public_html/piw/plugins/SecurityInfo/PhpSecInfo/Test/Application/php.php on line 34

#2547 - 404 error File does not exist: /home/piwik/public_html/themes/logo.png · Issue #2547 · matomo-org/matomo · GitHub
404 error File does not exist: /home/piwik/public_html/themes/logo.png

Not checked the changes in but hopefully these issues will be fixed for the next release (poss 1.6) :slight_smile:

Tom


(vipsoft) #3

Tom: the first three issues are handled by the autoloader; if you need to include/require manually, there’s something wrong with your environment

not sure about the last issue, but that typically means you have a custom logo


(tom_taylor) #4

Hi

What would be wrong with the environment then!?

The files exist, but your auto loader doesn’t load those class’s that are then to be extended.

Do you have errors disabled with your env!?

I’ve never had this issue before until Piwik 1.5.1, so unless you’ve got any idea’s why the issues happen, these are defects.

The last issue causes 404’s as the images dont exist, the code is wrong as it should check if the images exist in the themes directiory, instead it doesnt and still tries to load them.

logo and logo-header dont exist in themes, but they do in themes > default > images, so that is a defect too as i dont want your app causing 404s :wink:

Thanks

Tom


(vipsoft) #5

I run Piwik with E_ALL | E_STRICT, display_errors = on, log_errors = on

I’ve looked through the code. API/API.php defaults to themes/default/images/logo.png and logo-header.png. It refers to themes/logo.png and logo-header.png if and only if:


; global.ini.php (or config.ini.php) contains:
[branding]
use_custom_logo = 1

AND the respective file exists.

Sorry, I’m at a loss for an explanation of this gremlin.