Fatal error: Class 'Doctrine


(Benedetto) #1

Suddenly i’m getting this message, and i don’t know what to do?

Fatal error: Class ‘Doctrine\Common\Cache\ArrayCache’ not found in … core/StaticContainer.php on line 52

Can anybody help.

http://stats.benedettoapp.it/


(Matthieu Aubry) #2

Areyou deploying Piwik from git? maybe run php composer.phar install in the piwik directory?


(Benedetto) #3

I don’t really know what you mean, maybe run `php composer.phar install, i installed it with Softaculous in cPanel, and it worked just fine for many months, and just now i realised i get this error, but just a couple of days ago it worked just fine. don’t know exactly when it happened, i also tried to restore a backup form yesterday, but still the same, and also from 2 days ago but still the same, the database should be fine, what can i do?


(Benedetto) #4

This issue has been fixed, i didn’t find the cause, i just restored a manual back up (2 weeks old) i had of the whole directory and now it works.


(J de Silva) #5

I tried updating the script today and got this error message too. I tried your suggestion, matt, and this was returned:


Could not open input file: composer.phar


#6

Just for the records (and all people like me google for the error message):

Fall into a similar error “Fatal error: Class ‘Doctrine\Common\Cache\ArrayCache’ not found” yesterday.

Some directories (escpecially piwik/vendor/doctrine/cache) were missing.

This was because I unzipped the piwik-download and putting it in my own git repository. Unfortunately there are some directories in the piwik-build containing a .git directory. Git ignore these directories by default when importing into my own repository. Therefore the pulled version from my own repository was not working.