Failed to install piwik


(le_chaland) #1

hi

I tried to install piwik, during the installation, all work fine, environement tests, creation of database table …

But when i arrive at the end of the installation, i have theses lines:

Error parsing config/config.ini.php on line 10

in ‘/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/libs/Zend/Config/Ini.php’ at the line 102

#0 Piwik_ErrorHandler(2, Error parsing config/config.ini.php on line 10
, /var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/libs/Zend/Config/Ini.php, 102, Array ([filename] => config/config.ini.php,[section] => ,[config] => 1,[allowModifications] => 1))
#1 parse_ini_file(config/config.ini.php, 1) called at [/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/libs/Zend/Config/Ini.php:102]
#2 Zend_Config_Ini->__construct(config/config.ini.php, , 1) called at [/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/core/Config.php:87]
#3 Piwik_Config->__construct() called at [/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/core/Piwik.php:1022]
#4 Piwik::createConfigObject() called at [/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/core/FrontController.php:218]
#5 Piwik_FrontController->init() called at [/var/www/virtual/le-chaland.fr/htdocs/piwik4er5Xlfrqqs54Mt0prtS/index.php:51]

I removed, the time to test, my .htaccess restrictions but it don’t change anything.
Anyone can help me ?


(Matthieu Aubry) #2

this is a bug in Piwik.
I created a ticket http://dev.piwik.org/trac/ticket/481
in the meantime you can manually fix it by editing config/config.ini.php

if you have
username= myusername

change it adding double quotes around:

username= “myusername”

This should fix the bug. Please let us know if it works!


(le_chaland) #3

hi

Sorry for the delay, i don’t had received any email to advise me for your post.

I tried your correction but it’s don’t change anything.

I get the login panel, and after, theses sames worried lines …

Another thing which may help you, maybe: i put the strings-bloc given during installation in my footer, all the thing i obtain is a redcross. It’s don’t seem to be an invalid picture, when i right click over this redcross and look for the properties i have:

http://www.le-chaland.fr/piwik4er5Xlfrqqs5…ure%26ok%3D9595

I removed this script from my footer the time to solve the problem.

I have a remark too: do you thing it is a good thing that the datas for the login into piwik and the datas used by piwik to use the database are on the same file and not crypted. It is really a good security policy ? I dont’ think …

I wish to you and all the dev team & piwik users an happy new year 2009
Best regards.


(BabaPandey) #4

Try re-installing it. Sometimes due to missed file or corrupted files such error occurs. style_emoticons/<#EMO_DIR#>/cool.gif