Export more than 100 datefields


(Piko) #1

hi there,

thank your for your great work (piwik). i like everything and i’m really satisfied with your nice tool.

i have a litte question, how can i export more than 100 entries? all the time, when i click e.g. on the csv-export link on e.g. “list of keywords” i only get the last 100 entries. but i have more than 800! how or where can i change a/the parameter for that.

is that possible? thank you for answering.
pikolo


(Matthieu Aubry) #2

See:


(Piko) #3

thanks alot


#4

i have the same problem.

I used all the info from How to - Analytics Platform - Matomo
but nothing change!!!

Every time i am doing an export for keywords i have a limin about 100 rows!!!


(Matthieu Aubry) #5

the parameter filter_limit as documented in the API documentation: http://dev.piwik.org/trac/wiki/API/Reference
add filter_limit=500 to API request


#6

Really, folks, could you please give the answer to the real question:

How to change the filter_limit of the Export Buttons at the datatable_footer? I had to make those changes to the “datatable_footer.tpl” template file, and I don’t think that this is the right way. So the real question is: How to override these filter_limits and make this override permanent?

The Export Buttons are those funky links given to you when clicking onto the disk symbol at the bottom of the Website


(Matthieu Aubry) #7

Change the config setting called API_datatable_default_limit


#8

I don’t really think so, as I just checked, and this parameter has no value at my installation (which usually means “no limit”).

Perhaps I was not clear enough: to change those Limits for the Export Buttons you have to explicitly change the templates as they are hardcoded in them. My Question was not how to set a global value but to override those settings of the templates without changing the last.

A workaround is to change "filter_limit = ‘100’ " to "filter_limit = ‘’ in the file “datatable_footer.tpl”; but this possibly woul be broken after an upgrade. Anyway, this works for me.


(Matthieu Aubry) #9

sorry about the confusion… I forgot that we only fixed the issue after 1.6 release.

please use SVN this bug is fixed along already 25 tickets, this config setting works as expectedin trunk