Expanding rows in Referrer Websites, Outlinks etc hangs with "Loading"


#1

Hi all,

This has been happening for a while, but I’ve never quite got around to asking any questions about it. Basically, my Piwik installation seems to work fine in most ways, but when I view reports and try and click the + button by a row in the Referrer Websites, Downloads or Outlines panels, I just get an animation saying “Loading…” and it never actually loads. I’ve left this for up to an hour, and nothing has happened.

Any ideas what is going on here?

(I’m using the latest version of Piwik by the way)


(Matthieu Aubry) #2

Maybe this happens when you look at “Today” in the calendar? if so incraese the timeout in Settings>General settings to “100 seconds or 1000”


#3

Hi Matt,

I can’t find a timeout setting in General Settings? All I can find is a setting for how often to process reports (“reports will be processed at most every X seconds”). I’ve tried changing that, but it hasn’t helped.

I get the problem with it hanging on 'Loading…" regardless of what time period I’m viewing - it happens for Today, Yesterday, and completely random date periods.

Cheers,

Robin


(Matthieu Aubry) #4

Tha’ts surprising and definitely should not happen… it works OK for you on the demo? do you see any error in your server error logs?
can you also look with firebug for the HTTP request for requesting the data, see if it has content?


#5

Hi,

Sorry for the delay in replying.

I’ve tried it on the demo, and it works absolutely fine there. I’ve also checked my server’s error logs, and they’re completely empty.

However, Firebug is providing some interesting results. The console shows this:


Plugin file loaded index.php?module=Proxy&action=getCoreJs&cb=a615a764c9ffd81bc180a8984ac3d2da:1237
event.returnValue is deprecated. Please use the standard event.preventDefault() instead. index.php?module=Proxy&action=getCoreJs&cb=a615a764c9ffd81bc180a8984ac3d2da:5
Uncaught TypeError: Cannot call method 'search' of undefined index.php?module=Proxy&action=getCoreJs&cb=a615a764c9ffd81bc180a8984ac3d2da:276
Uncaught TypeError: Object #<Object> has no method 'indexOf' index.php?module=Proxy&action=getCoreJs&cb=a615a764c9ffd81bc180a8984ac3d2da:566

The first three lines appear as soon as I load the page, but the final line only appears when I click the item and the ‘Loading…’ message appears - so I think that must be related to it. The line of code that produces the error is:


if(self.param.viewDataTable&&self.param.viewDataTable.indexOf('graph')===0){delete self.param.filter_offset;delete self.param.filter_limit;}

Any ideas what’s going on here?

Cheers,

Robin


#6

Hi,

Does anyone have any idea what’s happening here, and what I can do about it?

Is this a bug - if so, where should I report it?

Cheers,

Robin


(Matthieu Aubry) #7

please try with the latest beta from Index of /


#8

I’ve just installed the latest version from latest.zip on builds.piwik.org, and I get exactly the same problem, with the same messages in the Javascript console.

Any ideas?


(Matthieu Aubry) #9

since it’s a random issue, it is hard for me to help. Maybe you can create a bug report on our issue tracker: http://dev.piwik.org/

Also can you reproduce this issue on the demo.piwik.org ?