Event tracking issue - preview works but not the live

I am able to see the event firing in the preview mode and not in the live environment for a lot of the event tracking that I had created.

Anyone faced that issue before? Is there any way to get unblocked on this?

Thanks, Sacha

Do you have proxy that could block some request?
How did you manage the DoNoTrack?
Is there no tracking filter on Matomo (on IP, on browser, etc.)?

1 Like

Hi,
Yes we have Proxy but the problem not at proxy the problem that we can’t see Event button click at live mode it show the link but not show the event click button
works fine at preview mode show the button event and links
photo_2021-12-07_13-09-13
how we can solve this?
Thanks , Ehab

1 Like

@heurteph-ei thank you for your response. I brought @Ehab_Hassan here who’s managing our web development. Looking forward to your positive response. Thanks, S

1 Like

Did you publish well the container?
Are you sure the version has been well saved? In order to be sure, try to create a new version, no change should be visible


In my case above, There is new changes, then my mast save did not work well. This is due to the timeout setting…

Hi Phillippe…thank you for writing to us…basis your response I went ahead and tried to create a new version of the container to publish…and yes while I am trying to publish the new version, I am seeing all of the tags and triggers in the " Changes since the last version" section that I had created months back…pls see screenshot below:

How do we resolve for this timeout setting…some of the old tags that were created are also not firing now…Pls advise the way forward


this second image

The solution for me was:

  1. Set max_execution_time=0 in the php.ini
  2. Set the same kind of option (long timeout, but maybe not infinite) in Apache… I don’t remember how much it has been set on our server (I have no access to this config), but I know that it is long enough… Maybe 3 or 5 minutes?

I m using Gridsome framework with vuejs where I can find the php.ini ?

Sorry, I don’t know this framework.

Thank you @heurteph-ei! anyone in this community that can support? I think the cms change is causing that issue but there must be a way to make it work… we’re working on an open-source peer-to-peer internet and just can’t use google analytics…

I spoke about the matomo php.ini file…
When you installed Matomo, you installed php files…
And in the root folder, you should find a php.ini file…

1 Like

Checking this with our web team. Thank you for your support @heurteph-ei :pray:


@heurteph-ei we check with support it is already max_execution_time=0` in the php.ini
so it is not time out problem

Did you try also the 2nd configuration?

In my case I had also to configure this…

@heurteph-ei
Hi Philip also checked and made it 3 min and restarting and still the same



what do u think the issue here?
Thanks for Support.

Which version of Matomo do you use?
I think some fixes have been done in last ones (the creation of a new container should take less time…)

we use last version I updated yesterday and same issue,
can we please make zoom and try to fix this issue we test everything and not solve yet and we need it urgent please contact me at mail
hassane@incubaid.com
Thanks,

Sorry, I don’t belong to Matomo team, so I won’t be able to zoom…