Error with loading


(Paul7() #1

Hello,

This afternoon, When i go to piwik index, it say me :

Error while connecting to: api.piwik.org. Please try again later.
Backtrace:

#0 C:\web\www\piwik\core\UpdateCheck.php(35): Piwik::sendHttpRequest(‘http://api.piwi…’, 2)
#1 C:\web\www\piwik\core\FrontController.php(237): Piwik_UpdateCheck::check()
#2 C:\web\www\piwik\index.php(64): Piwik_FrontController->init()
#3 {main}

It is a bug ?

Thanks


(vipsoft) #2

Are you running 0.4.3?

What is in your disable_functions in php.ini?


(Paul7() #3

[quote=vipsoft @ Aug 12 2009, 02:25 PM]Are you running 0.4.3?

What is in your disable_functions in php.ini?[/quote]

Yes i’m using the 0.4.3.

Morning it working fine and yersterday so.

in my php.ini the disable_functions is : “no value”.

It works if in FrontController.php i comment : Piwik_UpdateCheck::check();

Thanks


(Tehanor) #4

Same problem as me. I run the version 0.4.3.

I’ve overwritted the old one because i didn’t remembered my Piwik password. Then, after the installation, i’ve got the same message.

There are my disable functions :

;disable_functions = highlight_file, diskfreespace, exec, passthru, system, popen, fsockopen, pfsockpen, show_source, php_uname, ini_alter, ini_restore, getrusage, get_current_user, set_time_limit, getmyuid, getmypid, dl, leak, listen, chown, chmod, chgrp, realpath, tmpfile, link
disable_functions = set_time_limit, chown, chgrp


(vipsoft) #5

Thanks for reporting this.

I agree with commenting out the update check for now as it seems your systems might have some other restrictions (eg firewall) preventing Piwik from communicating with the update servers.

I’ve added more error checking for 0.4.4.


(Tehanor) #6

I’ve found the line Piwik_UpdateCheck::check();
But what do you mean with commenting it ? What am i supposed to change ?


(piwik-user) #7

[quote=Tehanor @ Aug 14 2009, 08:48 AM]I’ve found the line Piwik_UpdateCheck::check();
But what do you mean with commenting it ? What am i supposed to change ?[/quote]

I think, you have to comment it out - this way:
"/* Piwik_UpdateCheck::check(); */"

I’ve done so and now the error message don’t appear. My installation is now complete.

I also think, that our Intranet-Server don’t allow to connect external Servers.


(Tehanor) #8

It works ! style_emoticons/<#EMO_DIR#>/rolleyes.gif Thank you for your help


(toastbrot) #9

is it possible to turn this updatecheck off by a config-parameter? we do not need this update on our productive system and it does also not work, as one needs a proxy to go outside. if we could turn it of by config-file that would all be no problem on the productive. on the testing we use a different config file… thanx