Error while updating to 1.8.3

While trying to perform the one-click update to 1.8.3, I got this error message:

Fatal error: Undefined class constant ‘Piwik_ReportRenderer::HTML_FORMAT’ in [PATH_TO_PIWIK]/core/PluginsManager.php on line 427

([PATH_TO_PIWIK] being the path to Piwik on my server)

This messed up the whole installation, and I was unable to access Piwik at all. I had to delete and reinstall it. The subsequent database update seems to have worked fine.

Tracking works again, but I can’t view some of the reports, now getting the following error message:

Notice: Undefined index: enable_auto_database_size_estimate in [PATH_TO_PIWIK]/plugins/PrivacyManager/PrivacyManager.php on line 131

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [PATH_TO_PIWIK]plugins/PrivacyManager/PrivacyManager.php:131]#1 Piwik_PrivacyManager::getPurgeDataSettings(…) called at [PATH_TO_PIWIK]/plugins/PrivacyManager/PrivacyManager.php:318]#2 Piwik_PrivacyManager::shouldReportBePurged(…) called at [PATH_TO_PIWIK]/core/ViewDataTable.php:1431]#3 Piwik_ViewDataTable->hasReportBeenPurged(…) called at [PATH_TO_PIWIK]/core/ViewDataTable/GenerateGraphHTML.php:161]#4 Piwik_ViewDataTable_GenerateGraphHTML->buildView(…) called at [PATH_TO_PIWIK]/core/ViewDataTable/GenerateGraphHTML.php:125]#5 Piwik_ViewDataTable_GenerateGraphHTML->main(…) called at [PATH_TO_PIWIK]/core/Controller.php:247]#6 Piwik_Controller->getLastUnitGraphAcrossPlugins(…) called at [PATH_TO_PIWIK]/plugins/VisitsSummary/Controller.php:78]#7 Piwik_VisitsSummary_Controller->getEvolutionGraph(…) called at [PATH_TO_PIWIK]/plugins/VisitsSummary/Controller.php:23]#8 Piwik_VisitsSummary_Controller->index(…) called at [:]#9 call_user_func_array(…) called at [PATH_TO_PIWIK]core/FrontController.php:138]#10 Piwik_FrontController->dispatch(…) called at [PATH_TO_PIWIK]index.php:53]

Hope this helps debugging. Any quick remedy for me?

Many thanks!

EDIT: OK, figured it out. Disabling the PrivacyManager plugin seems to help… Which of course means that I can’t use it.

Notice: Undefined index: enable_auto_database_size_estimate in [PATH_TO_PIWIK]/plugins/PrivacyManager/PrivacyManager.php on line 131

This error happens because I think the config/global.ini.php wasn’t overridden by the update as it should have. PLease upload this file again (and possibly others that failed to be uploaded?)

Yes, reuploading the global configuration file fixed it. Thanks!

If there’s information about the updating error I can provide to help you debug, let me know.